Last Comment Bug 459357 - Support accessible name computation for SVG
: Support accessible name computation for SVG
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla20
Assigned To: alexander :surkov
:
:
Mentors:
: 633983 (view as bug list)
Depends on: 868789
Blocks: namea11y svga11y
  Show dependency treegraph
 
Reported: 2008-10-10 01:30 PDT by Aaron Leventhal
Modified: 2013-05-04 17:31 PDT (History)
8 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.20 KB, patch)
2012-12-19 00:09 PST, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description Aaron Leventhal 2008-10-10 01:30:32 PDT
I believe we will need to support the title attribute for SVG. Not sure if there are any other attributes that could influence the name (other than ARIA ones).
Comment 1 Robert Longson 2008-10-10 02:44:03 PDT
title attribute? SVG has a title element which is bug 329212.
Comment 2 Aaron Leventhal 2008-10-10 03:26:31 PDT
Robert, thanks. Anything else where a text equivalent might be specified?
Comment 3 Robert Longson 2008-10-10 03:30:31 PDT
http://www.w3.org/TR/SVG-access/#Links mentions the xlink:title attribute on links and title and desc elements
Comment 4 alexander :surkov 2012-11-13 21:10:55 PST
*** Bug 633983 has been marked as a duplicate of this bug. ***
Comment 5 alexander :surkov 2012-11-13 21:12:10 PST
from bug 633983:

A request from the wild, and should be easy enough. The idea is to map a child element <title> to the accessible name, and the <desc> to accessible description.

btw, there's a test case there.
Comment 6 alexander :surkov 2012-12-19 00:09:47 PST
Created attachment 693786 [details] [diff] [review]
patch
Comment 7 Trevor Saunders (:tbsaunde) 2012-12-20 14:19:33 PST
Comment on attachment 693786 [details] [diff] [review]
patch

>+function testDescr(aAccOrElmOrID, aDescr)
>+{
>+  var acc = getAccessible(aAccOrElmOrID);
>+  if (!acc)
>+   return;

I'd rather we didn't just return if the element doesn't have an accessible.

>+    {
>+      testName("svg1", "A name");
>+      testDescr("svg1", "A description");
>+      testName("svg2", "A tooltip");

test svg2 has no description?  maybe not because its important, but would be nice to know if we change it unintentionally
Comment 8 alexander :surkov 2012-12-20 19:52:17 PST
(In reply to Trevor Saunders (:tbsaunde) from comment #7)
> Comment on attachment 693786 [details] [diff] [review]
> patch
> 
> >+function testDescr(aAccOrElmOrID, aDescr)
> >+{
> >+  var acc = getAccessible(aAccOrElmOrID);
> >+  if (!acc)
> >+   return;
> 
> I'd rather we didn't just return if the element doesn't have an accessible.

getAccessible() reports an error if the given ID is not accessible so returning seems to be a right thing.

> >+      testName("svg1", "A name");
> >+      testDescr("svg1", "A description");
> >+      testName("svg2", "A tooltip");
> 
> test svg2 has no description?  maybe not because its important, but would be
> nice to know if we change it unintentionally

ok, good point
Comment 9 alexander :surkov 2012-12-20 19:56:18 PST
Btw, I think it'd be nice to keep name and description in the same place (not separately) since they are closely related. But keeping description stuff under name might be not nice. Alternatives: "textequivalent", "textequiv" or "namedescr". Which one do you think suites better?
Comment 11 Ryan VanderMeulen [:RyanVM] 2013-01-01 09:35:14 PST
https://hg.mozilla.org/mozilla-central/rev/18e5579588b5

Note You need to log in before you can comment on or make changes to this bug.