"Already running" message if profile directory doesn't exist

RESOLVED DUPLICATE of bug 278860

Status

Core Graveyard
Profile: BackEnd
RESOLVED DUPLICATE of bug 278860
9 years ago
2 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Remove a Firefox profile directory (or rename it), don't modify profile.ini. Start Firefox - you get a message "Firefox is already running, but not responding." The message on OS X: "A copy of Mozilla Firefox is already open." That's a very misleading message and it doesn't help fixing the issue.

Expected: If the directory of a profile in profile.ini doesn't exist - either create a new profile automatically or remove that profile from the list of profiles so that the user gets profile manager UI.

Tested with a Firefox trunk nightly (build 20081010021316).
(In reply to comment #0)
> Remove a Firefox profile directory (or rename it), don't modify profile.ini.
> Start Firefox - you get a message "Firefox is already running, but not responding."

Problem is re-produced with Fx Trunk on MS Win-XP SP3.
>profiles.ini (other profiles are defined)
> [Profile3]
> Name=Directory-Not-Found
> IsRelative=1
> Path=Profiles/Directory-Not-Found  (Directory-Not-Found doesn't exist)
(1) firefox.exe => profile selection dialog => choose Directory-Not-Found
    => "Firefox is already running, but not responding." 
(2) firefox.exe -P "Directory-Not-Found"
    => "Firefox is already running, but not responding." 

Bug 459638 is already opened for phenomenon of "Firefox is already running, but not responding." upon ;
 - "profile is already used", when started with "firefox.exe -P "profile_name"
   (both when "without -no-remote" and "with -no-remote")
 - "profile is not found ", when started with "firefox.exe -P "profile_name"
   (when "with -no-remote")
Setting dependency.
Depends on: 459638
Depends on: 278860
No longer depends on: 459638
It's a dupe of bug 278860 and doesn't depend on it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 278860
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.