Closed Bug 460241 Opened 12 years ago Closed 12 years ago

"Save all attachments" context menu

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows Vista
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 466016

People

(Reporter: deboot, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: 3.0b1pre

For e-mails with multiple attachments, enable an Attachments>Save all... context menu item for both the e-mail line context menu in the messages tree, but mainly also for the attachments area of the messageview (for Shredder, also in the Actions dropdown in the message header).

ATM, there is only Open, Save as, Detach, and Delete, which is quite inconvenient, you have to File>Attachments>Save all...

The Save as item actually does save all selected attachments, but it displays a save as dialog for every single one. When saving 20 attached files, pretty annoying.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I can confirm this is 100% reproducible and has been reported on many email clients. The only solution currently appears to be to downgrade to 2.0.0.17 to restore this functionality.
Confirmation, 100% reproducoble for Thunderbird Version 2.0.0.18 (20081105)
Same problem, 2.0.0.18/Windows XPSP3 (multiple installations). "Save all", "Detach all", "Delete all" are all grayed out in attachment context menu.
It appears that two issues are mixed here in this report:
- original suggestion is for 3.0, now duplicated by bug 466060;
- behavior observed in 2.0.0.18 is likely caused by bug 416284.
"behavior observed in 2.0.0.18 is likely caused by bug 416284."

I don't see the connection; 416284 regards detaching attachments which are then re-detachable, whereas this reported bug regards NOT being able to detach attachments in the first place (except individually or through other means than the default context menu).

466060 appears to be a different functionality bug, whereby the options are missing altogether, rather than merely greyed out, if I understand the discussion correctly.
I was referring to attachment 346404 [details] [diff] [review] in that bug, with some last-minute
changes for the Save-All item on branch in onShowAttachmentContextMenu(), but
of course may be mistaken. I've added Phil as Cc to clarify, as quite a few
reports came in also in the forums, and this was the best-fit recent checkin.
Not only "Save All" is grayed out, but also "Detach All" and "Delete All" which is very important.  Using the File/Attachments option can be cumbersome, especially when in version 2.0.0.17 they all worked very well.
This bug should be confirmed (and fixed), cause it is a sink of many user complains, see these post on MozillaZine an Geckozone (french forum):
http://forums.mozillazine.org/viewtopic.php?f=39&t=959985
http://www.geckozone.org/forum/viewtopic.php?p=488190
Discussion in german thunderbird forum:
http://www.thunderbird-mail.de/forum/viewtopic.php?f=26&t=38348

Workarounds:

1. Menu File > Attachments > ... is working in most cases

OR

2. Use the context menu in a blank area in attachment box WITHOUT selecting an attachment before
(In reply to comment #8)
> This bug should be confirmed (and fixed)

Note that bug 466016 has been filed and confirmed for this issue on branch.
1) "Menu/Attachments" works ONLY if you have not saved, detached or deleted ANY of the attachments.

2) I tried to not select an attachment in the attachment box and when right click is used, one of the attachments is highlighted and disables the "x All" in the menu.
Unclear if this was for branch or trunk originally, but per comment 4...
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466016
You need to log in before you can comment on or make changes to this bug.