Open New Message by Double Click opens Compose/Reply instead.

RESOLVED INCOMPLETE

Status

defect
RESOLVED INCOMPLETE
11 years ago
4 years ago

People

(Reporter: vicjohn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-10-11], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 

Running Thunderbird 2.0.0.16 in Win 2000 double click error began well after installation/upgrade to this version.  You double click the new message to open in a new window, but instead it opens the compose/reply window.  We upgraded Win 2000 to Win XP without making any changes to the Thunderbird version and imported existing settings of Thunderbird.  The double click error persisted in the Win XP.  Followed this with update to Thunderbird 2.0.0.17 and problem persists.

Problem exists only in the "Inbox" and does not affect any specific profile or folder, just the "Inbox".  Sent, Draft, etc are not affected by the glitch.

See Forum discussion here:  http://forums.mozillazine.org/viewtopic.php?f=39&t=54144&p=4747715#p4747715

Reproducible: Always

Steps to Reproduce:
1. open Thunderbird and allow get mail.
2. double click on new message to open.
Actual Results:  
Instead of Open message to read, we get Compose/Reply to...

Expected Results:  
Should have opened message in new window for viewing.

No error messages pop up.  Using default theme. Occurs only in the INBOX.  If new mail is filtered to folders, the folder message performs as expected.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
Check the settings in Tools > Account Settings > /account/ > Copies & Folders. Did you accidentally associate the Inbox as the Drafts folder?
Deborah please you can reply to rsx1m?
(Reporter)

Comment 3

10 years ago
It is not associated to the draft folder.  All the settings look normal.



(In reply to comment #1)
> Check the settings in Tools > Account Settings > /account/ > Copies & Folders.
> Did you accidentally associate the Inbox as the Drafts folder?
(In reply to comment #3)
> It is not associated to the draft folder.  All the settings look normal.
Also it happens with last release 2.0.0.22?

Comment 5

10 years ago
There is another group of settings for each identity, if you have multiple e-mail addresses associated with the same account. On the main page for that account find the Manage Identities button, this will list all defined ones. Highlighting and clicking Edit allows you to check the Copies & Folders settings specific for that identity.
(Reporter)

Comment 6

10 years ago
we are running 2.0.0.17
didn't even know there were that many version changes since last year. we'll look into possible updates as soon as scheduling permits.



(In reply to comment #4)
> (In reply to comment #3)
> > It is not associated to the draft folder.  All the settings look normal.
> Also it happens with last release 2.0.0.22?
(Reporter)

Comment 7

10 years ago
This had already been verified.  All of the identities are fine.  The double-click issue is present only in the Inbox (unfiltered mail).  There is no relationship to identities.



(In reply to comment #5)
> There is another group of settings for each identity, if you have multiple
> e-mail addresses associated with the same account. On the main page for that
> account find the Manage Identities button, this will list all defined ones.
> Highlighting and clicking Edit allows you to check the Copies & Folders
> settings specific for that identity.

Comment 8

10 years ago
I would to thank the person who opened this issue again.  I have been having this issue since at least .18 and have updated each at release, now using .22.

It is very frustrating to have suggestions like uninstall Thunderbird, try again, and what folders did you assign over and over and over again.  This problem has been on the boards several times.

Each time it gets ignored.  

P M Donovan
Did you also check that the Templates folder is set to an own folder, not the one you have problems with?

Comment 10

10 years ago
Again, every time this gets brought up, posters get a list of "possible" reasons, reply that they have already checked and nothing gets done.

If this is a Microsoft-type "feature," say so; this way you avoid people wasting time.
We can't fix it if we can't reproduce it, that's why we're asking.
Did you make sure an extension isn't causing it? (Try thunderbird.exe -safe-mode)

Comment 12

10 years ago
As have others, I have tried safe mode and disabling the few extensions I use with Thunderbird.

Comment 13

9 years ago
Why is there not response to the fact that the same error occurs when thunderbird.exe -safemode is used?
(Reporter)

Comment 14

9 years ago
Well, we are now up to 3.0.4
the double click problem has followed us through all the intervening versions.  Now we have an additional bonus with version 3.0.4.....we get to have two copies of the inbox. Remind me why we use Mozilla Thunderbird?????
(pinging bugs marked version 2.0)

Do you also see this problem in version 3.1? 
  http://getthunderbird.com/

If you do not, please close the bug with status set to RESOLVED and resolution set to WORKSFORME.
Whiteboard: closeme 2010-12-01
(Reporter)

Comment 16

9 years ago
We have just finished updating to 3.1.6 and the problem persists.

Comment 17

9 years ago
It is still a problem in 3.1.6; just confirming.

Updated

9 years ago
Whiteboard: closeme 2010-12-01
Do you see this when Thunderbird is started in safe mode?
And, do you see anything in tools | error console?

if you no longer see problem on newer release, please change resolution to WORKSFORME.
if you do see the problem on newer release, please update the bug with details.
Whiteboard: [closeme 2011-10-11]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 20

6 years ago
I have had this bug ever since I first started using Thunderbird around 5 years ago.  I have multiple identities.  None of the above suggestions seem to help.  I used to solve this by using the right click context menu but with the latest release 24.01 the sequence of the context menu has changed making it difficult!

Comment 21

4 years ago
This set of problems still exist as of now. I'm running version 31.3.0 of Thunderbird, and experience:

1) Double Inbox lines on the main tab
2) When double-clicking on new mail item it opens in 'Compose' mode rather than 'Read' mode.

Very annoying to have this continuing problem in such a great application.

Am willing to send my entire set of Thunderbird files if needed to debug!
Make sure you did not set the drafts or templates folder to point to that Inbox

Other things to try: safe-mode: Tools | Restart with Add-ons disabled

Comment 23

4 years ago
Magnus,

I tried all the proposed solutions from the above comments.
I made sure no drafts or templates folders point to Inbox.
I tried safe-mode, and only one Inbox shows up (yey!), but running in safe mode all the time is not a good option. 
In safe-mode double-clicking on new mail item *still* opens in 'Compose' mode rather than 'Read' mode.
Any other suggestions?
That (the one part) works in safe-mode means and extension/theme is causing it. You can disable them one by one to find out which one.

If you want you can send me your zipped profile for debuggin. (Be sure to delete signons.sqlite and other data you don't want me to have.)

Comment 25

4 years ago
Magnus Melin,

Thanks for your patience, I found a resolution to both problems, as follows:

1) Backed-up all my Thunderbird files (by simply shutting down Thunderbird and copying the entire Thunderbird directory).

2) Uninstalled Thunderbird, then deleted various Thunderbird files on my system that were not cleaned up by the installer.

3) Installed a freshly downloaded copy of Thunderbird.

4) Set up my email addresses fresh using the wizard.

5) Restored my backed-up mail in "Local Folders" to the new directory created by the install: <DiskDriveHere>:\Users\<UserNameHere>\AppData\Roaming\Thunderbird\Profiles\<CodedNameHere>.default\Mail\Local Folders

6) During the restoration I noticed that there were one directory and two files in the "Local Folders" directory that had not existed in the fresh install, they were:

Directory: Inbox.mozmsgs
File: Inbox
File: Inbox.msf

I deleted these files from my new installation directory.

These steps resolved both problems:
1) Double Inbox lines on the main tab
2) When double-clicking on new mail item it opens in 'Compose' mode rather than 'Read' mode.

I suspect, but do not know for sure, that simply eliminating the unnecessary Inbox directory and the two Inbox files from "Local Folders" would have (by itself) solved the problem.

This represents to me a complete solution to this issue.

MRA
You need to log in before you can comment on or make changes to this bug.