Inter-Window tab dragging disables closing the tabs in the dragged-to window.

RESOLVED DUPLICATE of bug 456002

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 456002
9 years ago
9 years ago

People

(Reporter: Natch, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

See STR, the following errors appear in the console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/tabbrowser.xml :: _beginRemoveTab :: line 1443"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/tabbrowser.xml ::  :: line 2541"  data: no]

Reproducible: Always

Steps to Reproduce:
1.Open ff and then open a New Window
2.in the 1st window visit a site (I used yahoo)
3.drag the tab to the 2nd window to the right side of the currently open tab
4. the old tab becomes the one to the right, try hitting the [x].
Actual Results:  
Nothing happens, get the errors from the console.

Expected Results:  
Tab should close!
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081016 Minefield/3.1b2pre

I tested this but was not able to reproduce. This bug looks similar to Bug 460270.

Comment 2

9 years ago
This is most likely a duplicate of bug 456002.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456002
You need to log in before you can comment on or make changes to this bug.