exporting bookmarks as html file does not export tags

RESOLVED DUPLICATE of bug 423197

Status

()

RESOLVED DUPLICATE of bug 423197
10 years ago
9 years ago

People

(Reporter: jbecerra, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4pre) Gecko/2008101704 GranParadiso/3.0.4pre

If you export your bookmarks as an html, the resulting file does not have the associated tags. So when you import them using, Fx3.1 for example, you end up with a bunch of bookmarks with no tags. If you export them as a .json file, the tags are included.

Steps:

1. Make sure you have a few bookmarks and that some of those have tags. 
2. Open the bookmarks library and click on the star icon, and then select the Export HTML option.
3. Save the file as bookmarks-test.html on your desktop.
4. Launch Fx3.1 with a new profile.
5. Open the boomarks library, click on the star icon, and select Import HTML.
6. Search for one of the tags you remember from step 1

Expected: You should be able to find some tagged bookmarks. Some urls should have tags associated with them, and they should be shown in the location bar.

Actual: Bookmarks library cannot find exact match for the tag. When you go to the location bar, you'll see that the dropdown will have a list of "starred" urls, but no tags associated with them.
Flags: wanted1.9.0.x?
(Reporter)

Updated

10 years ago
OS: Mac OS X → All
Hardware: Macintosh → All
(Reporter)

Comment 1

10 years ago
Happens in Windows and Linux as well.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423197
Flags: wanted1.9.0.x?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.