Last Comment Bug 423197 - html export does not back up tags
: html export does not back up tags
Status: VERIFIED FIXED
[papercuts][migration]
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: P3 normal with 14 votes (vote)
: Firefox 30
Assigned To: Marco Bonardo [::mak]
:
: Marco Bonardo [::mak]
Mentors:
: 453769 460529 (view as bug list)
Depends on: 968177
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 13:51 PDT by Jim Jeffery not reading bug-mail 1/2/11
Modified: 2015-03-16 14:49 PDT (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
write TAGS to bookmarks.html on export (1.61 KB, patch)
2011-07-06 22:29 PDT, Mike Frysinger
no flags Details | Diff | Splinter Review
unbitrotted (2.14 KB, patch)
2012-05-04 14:49 PDT, Dietrich Ayala (:dietrich)
no flags Details | Diff | Splinter Review

Description Jim Jeffery not reading bug-mail 1/2/11 2008-03-15 13:51:05 PDT
Using the Library to 'Export' you bookmarks does not export 'tags' or unfiled bookmarks. 

Wasn't this supposed to be fixed by;
https://bugzilla.mozilla.org/show_bug.cgi?id=396806

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008031506 Minefield/3.0b5pre Firefox/3.0 Firefox/2.0.0.12 ID:2008031506
Vista HP
Comment 1 Dietrich Ayala (:dietrich) 2008-03-15 14:37:56 PDT
Please read comment #5 of the referenced bug: https://bugzilla.mozilla.org/show_bug.cgi?id=396806#c5.

This is not a regression, as HTML export has never has supported export of that data.

This is not dataloss, since even if you import it, it copies the imported data into the existing bookmarks collection, does not replace it. Which is the same behavior for quite a while (since the early alphas iirc).

Basically, the HTML serialization is not capable of supporting all the features needed for full and complete backup of Places data (tags, annotations, multiple bookmark roots), without convoluting that format even further. JSON provides full backup and restore capabilities.

I've changed the summary to reflect the specific problem.
Comment 2 Brian Polidoro 2008-03-15 14:47:25 PDT
Unfiled bookmark folder export is Bug 405936.
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2008-03-19 11:15:29 PDT
This will not block the final release of Firefox 3.
Comment 4 ricardo.aratani@gmail.com 2008-03-29 08:49:31 PDT
It would be nice to make it work with del.icio.us tags, also.
I tried to import my bookmarks to firefox 3 beta 4 and lost the tagging.
Comment 5 Heath 2008-04-12 11:35:45 PDT
This is important for roaming capabilities. Maintaining bookmarks is a hassle, but I like the tagging feature in FF3 - especially its role in Places - and do not want to resort to a third party add-on like del.icio.us which boasts an experience apart from FF3 Places.
Comment 6 Jim Jeffery not reading bug-mail 1/2/11 2008-04-13 16:34:03 PDT
With regards to comment #1, and the fact JSON is now active, and the Library has been updated to reflect that 'export/import' is for html only, and there is not html support for tags and other enhancements now provided by Places, I would guess this bug should now be marked WONTFIX ?

Comment 7 Heath 2008-04-14 08:05:37 PDT
(In reply to comment #6)
There's also no HTML support for the date when a bookmark was added or for either an encoded icon or icon URL, but they are in bookmarks.html now. A simple solution for truly exporting bookmarks and, more importantly, backing them up - since people would not want their tags lost, and backup should be just that - is to have, for example, an attribute TAGS that is simply a comma-delimited list just like how you enter tags.

Comment 8 Steve England [:stevee] 2008-09-05 03:36:26 PDT
*** Bug 453769 has been marked as a duplicate of this bug. ***
Comment 9 Jay Freeman 2008-09-06 13:34:23 PDT
This is how delicious do it:

<DT><A HREF="http://www.longshot.com/~kmixter/gmailui.html" LAST_VISIT="1210301148" ADD_DATE="1210301148" TAGS="thunderbird,extension,software,e-mail">GMailUI: Thunderbird Extension</A> 

Couldn't Mozilla adopt this format for export and import through HTML?

Ma.gnolia.com:

<A HREF="http://www.tiddlywiki.com/" ADD_DATE="1137664267" LAST_MODIFIED="1172879027" TAGS="wiki, free, open, source, wikiwiki, tiddlywiki">TiddlyWiki - a reusable non-linear personal web notebook</A> 
 <DD>Welcome to TiddlyWiki, a free MicroContent WikiWikiWeb by JeremyRuston. It's written in HTML, CSS and JavaScript to run on any modern browser without needing any ServerSide logic. It allows anyone to create personal SelfContained hypertext documents that
 <DT>

What is the point of having all the trouble of adding tags the bookmarks if we can't export them with the bookmarks?

These two services understand this, do you?
Comment 10 Phil Ringnalda (:philor) 2008-10-17 16:44:07 PDT
*** Bug 460529 has been marked as a duplicate of this bug. ***
Comment 11 Marcia Knous [:marcia - use ni] 2009-01-17 09:33:26 PST
I just hit this bug when I was trying to move a set of bookmarks from my trunk profile to my 1.9.1 profile. I found it odd that the tag data did not go with the bookmarks. And since the JSON export would replace my bookmarks, I am not sure I had too many other options when I was trying to move my bookmarks from one profile to another without losing the tags.
Comment 12 Gervase Markham [:gerv] 2009-11-26 06:41:52 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Comment 13 Mitra Ardron 2010-12-17 01:46:21 PST
This bug is still here, and with Delicious shutting down it seems a fair number
of people are trying to move bookmarks around, but failing in part because of
the import/export path through Firefox is broken (losing the tags). 


See bug #416611 for the import bug.
Comment 14 Fausto 2011-06-29 09:54:58 PDT
This bug is still present in Firefox 5.

The format proposed on comment 9 would be a simple and elegant solution to the problem.
Comment 15 Mike Frysinger 2011-07-06 22:29:07 PDT
Created attachment 544411 [details] [diff] [review]
write TAGS to bookmarks.html on export

this seems to work for me.  when i export my bookmarks, i now get a nice TAGS="..." tag in each <a> bookmark tag as appropriate.

note: ive never hacked on mozilla/firefox before, so i have no idea if this code is correct or how to go about getting it merged.
Comment 16 gagarine 2012-04-23 21:24:00 PDT
#15 works for import? I'm looking for import from delicious... WITH tags.
Comment 17 Mike Frysinger 2012-04-23 21:28:33 PDT
please read comment 13
Comment 18 royroyers 2012-05-02 00:07:25 PDT
(In reply to Mike Frysinger from comment #15)
> Created attachment 544411 [details] [diff] [review]
> write TAGS to bookmarks.html on export
> 
> this seems to work for me.  when i export my bookmarks, i now get a nice
> TAGS="..." tag in each <a> bookmark tag as appropriate.
> 
> note: ive never hacked on mozilla/firefox before, so i have no idea if this
> code is correct or how to go about getting it merged.

hi bro, could you please tell me or give some instructions to be able to install your patch? i really need export with tags...
thanks...
Comment 19 royroyers 2012-05-03 22:52:40 PDT
Comment on attachment 544411 [details] [diff] [review]
write TAGS to bookmarks.html on export

so... what do i have to do with this? please tell me...
Comment 20 gagarine 2012-05-04 05:42:23 PDT
I made a binary version for OSX with this patch and #416611 from Firefox 12.0 so it's easier to try and test.

http://dl.dropbox.com/u/10215109/Firefox-patched.dmg
Comment 21 Dietrich Ayala (:dietrich) 2012-05-04 14:49:13 PDT
Created attachment 621187 [details] [diff] [review]
unbitrotted

needs to remove spaces after comma maybe, and also needs a unit test.
Comment 22 royroyers 2012-05-06 23:21:05 PDT
(In reply to gagarine from comment #20)
> I made a binary version for OSX with this patch and #416611 from Firefox
> 12.0 so it's easier to try and test.
> 
> http://dl.dropbox.com/u/10215109/Firefox-patched.dmg

could you help me to try this patch in my pc please? i really need it and i dnt kown what to do please please man
Comment 23 oliver.saunders 2012-10-05 11:14:32 PDT
If it is not possible to embed tag data within HTML could it at least be made clear that tags will not be saved as part of export HTML?
Comment 24 perdrisat 2012-10-07 03:43:43 PDT
(In reply to royroyers from comment #22)
> (In reply to gagarine from comment #20)
> > I made a binary version for OSX with this patch and #416611 from Firefox
> > 12.0 so it's easier to try and test.
> > 
> > http://dl.dropbox.com/u/10215109/Firefox-patched.dmg
> 
> could you help me to try this patch in my pc please? i really need it and i
> dnt kown what to do please please man

Nop sorry the binary is only for OSX. If you want to do it for PC you will have to try to patch... The easiest will be to use a mac of a friend.
Comment 25 s3rj1k 2013-10-29 01:10:53 PDT
Couldn't we just repurpose description field for coma separated tags list for the first line and add description on next line? (just like multiline description is done in html export)
Comment 26 Marco Bonardo [::mak] 2014-03-03 14:50:29 PST
with bug 968177, we are now exporting tags in html
Comment 27 Andrei Vaida, QA [:avaida] – please ni? me 2014-04-24 02:42:12 PDT
This issue is verified fixed on Aurora 30 2014-04-23 (Build ID: 20140423004003) and Nightly 31 2014-04-23 (Build ID: 20140423030202), using:
- Windows 7 64-bit [1],
- Ubuntu 12.04 32-bit [2],
- Mac OS X 10.9 [3].

1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
2. Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
3. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
Comment 28 Thomas Chilinski 2015-03-15 12:54:33 PDT

I recently lost all my recent bookmarks as well. 

I few days ago decided to reinstall eveything all my data was backed up exept my firefox bookmarks.
I used my laptop to confirme that the import bookmarks feature worked. ( I was mistaken )

After two days i decided to re-install eveything again. but I lost my recent bookmarks. More than a few of them were important. I had to track them down by hand. 

After some experimentation i found , one can backup there bookmarks with the following procedure.

In order to backup your favorites, can must first back with the .JSON option. 
then import the html file to resore ones icons.

This appears to work but, I highly recommend setting up the firefox sync feature as part of backing up ones data. 

****************************************************************************************************
I found a workarrond for this problem which is to install chrome and load and extension for tags. 
[Problem Solved]
Comment 29 Marco Bonardo [::mak] 2015-03-16 14:49:23 PDT
*** Bug 1141755 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.