W3C-compliant web page badly midrendered

VERIFIED DUPLICATE of bug 25228

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 25228
19 years ago
19 years ago

People

(Reporter: bugzilla, Assigned: karnaze)

Tracking

({testcase})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The front page at http://wonko.com/ is perfectly HTML 4.0 and CSS compliant 
according to the W3C validators. The page consists of one large table with 
three columns (a left sidebar, the page body, and a right sidebar). The left 
sidebar's width is set to 120 pixels, yet Mozilla M16 renders the page with the 
left bar taking up the majority of the browser window. Also, the CSS file for 
the site (http://wonko.com/novashare.css) specifies table borders, but Mozilla 
does not render them. 

This site renders correctly in IE 4.0+ and in Opera.
The problem with the left column being too wide has been fixed since M16.
It works fine in build 2000-07-20-08 (if you remove the empty line before the
<!DOCTYPE>, see bug 45832.)

The problem with the border is caused by the TABLE elements having specified
border=0. It seeems that this overrides CSS style for the table cells.
I will attach a small testcase for the border problem.
Keywords: testcase

Comment 3

19 years ago
setting status to new, updating component to HTML tables and reassigning
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
QA Contact: doronr → desale
The remaining border problem is a duplicate of
bug 25228 "Tables with TD CSS borders and border=0 don't show borders"

*** This bug has been marked as a duplicate of 25228 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.