Closed Bug 460819 Opened 13 years ago Closed 12 years ago

"File > Compact Folder" is not available for News Account and subscribed newsgroups in Shredder

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: nir.sen, Assigned: mkmelin)

Details

(Keywords: regression, Whiteboard: [fixed by bug 473642])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081020 Minefield/3.1b2pre
Build Identifier: 

Recently I have noticed that File > Compact folders Menu Item is grayed out when any News account or NG folder is selected in folder pane.

Currently I'm experiencing this in

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008071903 Thunderbird/3.0a2pre 

Reproducible: Always
Version: unspecified → Trunk
This happens in the latest nightly build in Windows XP SP3, too. The question is if there is anything to compact when it's grey. It's still grey for me when I tried setting the folder for offline use (though my setting in about:config that auto compacts after every change I make may be fooling this and I've long forgotten what line did that.) Do you have the folders set for offline use? If not, then right click on an unread newsgroup folder, such that it has messages that are older than the time you have set to keep the messages (for good measure). On the menu that pops up go to Properties > Offline and make sure the box is checked allowing for offline use. Click the download button that is right underneath it. Then left click on the newsgroup folder. For good measure, mark all of the messages as read. Click on another newsgroup, then on the test newsgroup again. Is the compact menu option still greyed out?
Does compact news folders ever do anything?
I'm not 100% sure, but I have heard people say on another bug ticket that there isn't anything to compact unless the messages are downloaded and stored for offline use. They could have been mistaken, though. Unfortunately, I've no idea what bug it was anymore. 

Even if they are right, I suppose it's possible (though unlikely) that Thunderbird may automatically compact the newsfolders to match one of fields in Tools > Account Settings > Syncing and Disk Space (On left under the news server). On the other hand, the ability to compact news folders may not exist at all. I'd have to ask someone about these things, though.
(In reply to comment #1)
> Do you have the folders set for offline use?

Yes. 2 of 3 are set for offline use.

Under same situation Tb 2.0.0.18 makes 'Compact' menu item available under File menu. Same is not available under latest nightly build.
(In reply to comment #2)
> Does compact news folders ever do anything?

I think If you have set a Newsgroup for offline use and delete any downloaded message from newsgroup then compact action removed it from corresponding mbox file.
But how do you delete the downloaded message from the newsgroup?
backend?
Status: UNCONFIRMED → NEW
Component: General → Backend
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Hardware: PC → All
I'll take this - I've working on various compaction issues. This is mostly a front end issue, this bug, that is.
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
Assignee: bienvenu → nobody
Component: Backend → Mail Window Front End
Product: MailNews Core → Thunderbird
QA Contact: backend → front-end
Target Milestone: --- → Thunderbird 3.0b2
Didn't test now, but I'm pretty sure this is from the nntp check in IsCompactFolderEnabled()
http://mxr.mozilla.org/comm-central/source/mail/base/content/mailWindowOverlay.js#1941

My questions still remain though. Is it really supported, and if so how do you delete news messages in the first place?
sorry, it's for compacting the offline store, if any - news messages go away when they're expired from the server, or you've set up retention settings.
But why would you ever have any reason to do it manually?
Ah, with offline + retention settings...?
yes, plus we don't currently do any compaction of anything by default. I'm planning on doing automatic idle time compaction, and if we do, this will become somewhat moot.
(In reply to comment #13)
> yes, plus we don't currently do any compaction of anything by default. I'm
> planning on doing automatic idle time compaction, and if we do, this will
> become somewhat moot.

I think bienvenu intended to stay assignee
Assignee: nobody → bienvenu
Assignee: bienvenu → mkmelin+mozilla
Target Milestone: Thunderbird 3.0b2 → Thunderbird 3.0b3
The check from comment 9 got removed with bug 473642.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 473642]
You need to log in before you can comment on or make changes to this bug.