Dlist within a DList does NOT work on Shredder

VERIFIED DUPLICATE of bug 542947

Status

Thunderbird
General
VERIFIED DUPLICATE of bug 542947
10 years ago
8 years ago

People

(Reporter: Bob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; .NET CLR 3.5.21022)
Build Identifier: 3.0a3

Yes, it's worked for at least 2 years now.

I'll file the report.

THANKS for the info.

-Bob



> Date: Mon, 20 Oct 2008 19:37:58 -0400
> From: vseerror@Lehigh.EDU
> To: BOB_UMPHRED@HOTMAIL.COM
> Subject: [Fwd: [Hendrix] Problem with Distribution List within Distribution List in address Book.]
> 
> Bob, has that ever worked? I'm not aware a list can reference list.
> 
> if that worked and now it doesn't please file a bug
> https://bugzilla.mozilla.org/enter_bug.cgi?product=Thunderbird&format=guided
> 
> 
> -------- Original Message --------
> Subject: [Hendrix] Problem with Distribution List within Distribution 
> List in address Book.
> Date: Thu, 16 Oct 2008 20:24:24 -0500
> From: Robert Umphred <hendrix-no-replyatmozilladotorg>
> Newsgroups: mozilla.feedback.thunderbird.prerelease
> 
> Name: Robert Umphred
> Email: BOB_UMPHREDatHOTMAILdotCOM
> Product: Thunderbird Release Candidate
> Summary: Problem with Distribution List within Distribution List in 
> address Book.
> 
> Comments:
> Running Alpha 3 of Shredder. I have a Dlist called TEAM, it has a few
> individual names in it, PLUS it has a reference to another DList called
> LI-TEAM.
> 
> The people on TEAM got the email OK, however, Shredder tried to send to
> a USER named LI-TEAM, and did not substitute the email address in LI-TEAM.
> 
> Had to send to LI-TEAM seperately.
> 
> Error:
> ---------------------------
> Hi. This is the qmail-send program at
> smtpauth20.prod.mesa1.secureserver.net.
> I'm afraid I wasn't able to deliver your message to the following addresses.
> This is a permanent error; I've given up. Sorry it didn't work out.
> 
> <LI-TEAM@smtpauth20.prod.mesa1.secureserver.net>:
> Sorry, no mailbox here by that name. (#5.1.1)
> ------------------------------
> 
> -Bob
> 
> 
> Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; 
> rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
> From URL: 
> http://hendrix.mozilla.org/?product=Thunderbird%20Release%20Candidate
> 
> Note to readers: Hendrix gives no expectation of a response to this 
> feedback
> but if you wish to provide one you must BCC (not CC) the sender for them to
> see it.



Reproducible: Always

Steps to Reproduce:
1.Create a Distribution List, Eg: DLista
2.Create a Distribution list, EG: Dlisb, and have people in it, PLUS reference DLista.
3.
Actual Results:  
If you send a email to DListb, it sends to the INDIVIDUAL people in DListB, then tries to send to DLISTA, thinking that it's an INDIVIDUAL person, Not another Dlist. 


Expected Results:  
An email is supposed to be sent to DlistA people AND Dlistb people.

This has been working for at least the past 2 years in Thunderbird.
Does not work with the upgrade now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 40301
Status: RESOLVED → VERIFIED

Updated

8 years ago
Duplicate of bug: 542947
You need to log in before you can comment on or make changes to this bug.