Double-click + text copy of last word on line copies \r\n as well

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: jhg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080914)

Password reset emails usually take a form similar to:

---BEGIN EXAMPLE---

To use the new password you need to activate it. To do this click the link provided below.

http://forum.obfuscated.com/profile.php?mode=...

If sucessful you will be able to login using the following password:

Password: SunSM9yL

You can of course change this password yourself via the profile page. If you have any difficulties please contact the board administrator.
---END EXAMPLE---

When you hilight the password by double-clicking and then copy it (context
menu or Ctrl-C) the hilight encompasses the word only (no trailing blank is
hilighted) but the copy buffer contains a trailing \r\n.  

If you then do the natural thing and paste this into the login form of the
website for which you requested a reminder, the login fails because the
pasted text contains the extra \r\n.  It took me several rounds back and
forth with the forum sysadmin to figure out what was happening (actually,
only when it happened on a SECOND unrelated site did I realize it was most
likely a local problem).


Reproducible: Always

Steps to Reproduce:
You can reproduce this by browsing to a plain-text email in the 3-pane window,
double-clicking on the last word on a line (where there is no trailing
punctuation), and copy/pasting the selection into a text editor.  The cursor
will end up on the line after the pasted word.  
Actual Results:  
The cursor will end up on the line after the pasted word indicating that \r\n
was pasted as well as the selected word.

Expected Results:  
The past should paste only the selected characters without the \r\n and the
cursor should remain on the same line.

Contrast this with the behavior if you select the word by clicking and 
dragging over it.  The selection looks the same but there's no trailing
\r\n in the copy buffer.
Don't have the bug number, but this is resolved on trunk. (= for thunderbird3)
->WFM
URL: n/a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 2

8 years ago
Similar (for Firefox): bug 464789, bug 637895.
You need to log in before you can comment on or make changes to this bug.