Closed Bug 461826 Opened 11 years ago Closed 11 years ago

.ics attachments from Thunderbird/Lightning not compatible with iCal

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bertosmailbox, Assigned: dbo)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Unsure

When I receive an .ics file from someone using Thunderbird/Lightning, the attachment is not imported by iCal.  I've determined the problem has to do with the first line in .ics file being blank.  Once the blank line is removed, iCal is able to use the file without problems.

Is this blank line at the top of the .ics file erroneous?

Thanks!

Reproducible: Always

Steps to Reproduce:
1. Receive an email with a .ics file from a Thunderbird/Lightning client
2. Click on it in Mail.app (OS X 10.5.5)
3. Watch iCal tell you this file is corrupt.
4. Save the file to the desktop
5. With an editor open up the file and remove the first line, which is blank
6. Click on the file and watch iCal happily use it.
Actual Results:  
.ics file needs manual editing before iCal can use it.

Expected Results:  
.ics file should be usable with no manual editing.  My guess is that this blank line is erroneous and should not be there to begin with.
WFM. There is no LF at the beginning and iCal correctly import the invitation (invite.ics); tested on Leopard's Mail.app/iCal.
Thanks for the update.  Here is some more information.  Here's the software in question on my end:

Thunderbird: 2.0.0.17
Lightning: 0.9

I'm also going to add an attachment with the raw mail message.  You can see that there are two blank lines between the mail headers and the .ics body.

Daniel, is your Thunderbird sending an inline attachment, or is it encoding it; as you can see, it's inline over here.  Maybe there is a setting in Thunderbird for this?

Thanks.
Here is a mail message with a calendar invitation.  It contains two blank lines between the mail headers and the .ics body.  The second of these new lines is being interpreted as the first line of the .ics file.
Ok, I see you are sending with Outlook 200 compat mode. I can reproduce it now, taking the bug.
Assignee: nobody → daniel.boelzle
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Attached patch fixSplinter Review
Attachment #345163 - Flags: review?(philipp)
Comment on attachment 345163 [details] [diff] [review]
fix

r=philipp
Attachment #345163 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/b057a77bb9e3>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Mac OS X → All
Hardware: Macintosh → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Duplicate of this bug: 462431
Checked with lightning build 20081030062620 -> VERIFIED.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 465318
Duplicate of this bug: 477111
Duplicate of this bug: 525880
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.