Closed Bug 461957 Opened 11 years ago Closed 11 years ago

SeaMonkey en-US installer files and check-locales.pl disagree about variable usage

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: mcsmurf)

Details

Attachments

(1 file)

http://hg.mozilla.org/comm-central/rev/0e391b0e5160 for bug 459435 made us run check-locales.pl against installer's L10n files to detect wrong variable usage, but we're not running it against en-US.
This made us end up applying stricter criteria to locales than en-US and our en-US files actually failing the checks.

Either we're using variables wrongly in SeaMonkey en-US installer files or the checker script is wrong.
I intentionally linked a full log, as the short logs only show some snippet of the error list, while the full one also shows where the error output starts.
Yes, the problem is caused by the installer strings and the changes by Bug 399665. That one is not implemented yet in the SeaMonkey installer. There's no SeaMonkey installer bug yet to port this to the SeaMonkey installer, but I'll file one and mark as blocking this bug.
Guys, pls, comment out lines 164-167 in http://hg.mozilla.org/comm-central/file/0e391b0e5160/suite/locales/Makefile.in so we can get l10n win builds again. There are no builds since 19/10/08

From what I remember this script isn't comparing locale with en-us, just looking for entities obsoleted in Bug 399665 and that's why we fail. There's really no need to have it there until Bug 399665 is ported. It's just blocking us from testing.
Attached patch PatchSplinter Review
Just remove this for now. Not sure if it's worth to port Bug 399665 to SeaMonkey, re-enabling that check is quite easy though.
Assignee: installer → bugzilla
Status: NEW → ASSIGNED
Attachment #345967 - Flags: review?(kairo)
Comment on attachment 345967 [details] [diff] [review]
Patch

r=me as long as it will be re-added once we port bug 399665
Attachment #345967 - Flags: review?(kairo) → review+
Checked in, comm-central rev 21dc49e33c23
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.