Last Comment Bug 462222 - getZOrderDOMWindowEnumerator broken on Linux and Mac
: getZOrderDOMWindowEnumerator broken on Linux and Mac
Status: RESOLVED FIXED
: fixed1.9.1
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 3.6
Assigned To: Dão Gottwald [:dao]
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 156333 450576
Blocks: 528440 530298 689513 874566
  Show dependency treegraph
 
Reported: 2008-10-29 13:43 PDT by :Ehsan Akhgari (out sick)
Modified: 2013-09-08 00:05 PDT (History)
11 users (show)
mconnor: blocking‑firefox3.5-
bugzilla: blocking‑firefox3.6-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
don't assume that mac works (2.31 KB, patch)
2009-01-10 06:24 PST, Dão Gottwald [:dao]
no flags Details | Diff | Review
updated (checked in) (805 bytes, patch)
2009-01-12 17:22 PST, Dão Gottwald [:dao]
mconnor: review+
mconnor: approval1.9.1+
Details | Diff | Review

Description :Ehsan Akhgari (out sick) 2008-10-29 13:43:52 PDT
getZOrderDOMWindowEnumerator seems to be working only on Windows.  We need to adjust the #ifdefs at the following places accordingly:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#4267

http://mxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserContentHandler.js#253
Comment 1 Justin Dolske [:Dolske] 2008-10-30 18:35:33 PDT
Bug 456439 will be adding another copy of this code to nsBrowserGlue.js as well.
Comment 2 Mike Connor [:mconnor] 2008-11-03 01:06:36 PST
Yeah... we need to fix this.

bug 156333 is the longstanding Linux bustage.
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2008-11-11 22:46:57 PST
As per comment 2, dunno why he didn't flip the flag himself ;)
Comment 4 Dave Townsend [:mossop] 2009-01-09 03:35:44 PST
Looks like this isn't going to get fixed on Mac anytime soon. Ehsan, do you have a good understanding of the changes we need to handle this?
Comment 5 :Ehsan Akhgari (out sick) 2009-01-09 04:20:56 PST
Without the dependencies being fixed, there is nothing to do here.  This bug is mostly about removing the conditional code inside of BROKEN_WM_Z_ORDER blocks, once the dependencies are fixed.

Given that bug 450576 is blocking1.9.1-, and bug 156333 is wanted1.9.1+, I'm not sure how this one ended up being blocking1.9.1+.  Turning the flag to ? for reconsideration.
Comment 6 Dave Townsend [:mossop] 2009-01-09 04:27:56 PST
bug 450576 was previously blocking but josh has concluded that it is too risky to take for 1.9.1, so we can't block here either.
Comment 7 Mike Connor [:mconnor] 2009-01-09 04:56:00 PST
Pretty sure we still have to fix the ifdefs so that we don't assume mac will work...
Comment 8 Dão Gottwald [:dao] 2009-01-10 06:24:53 PST
Created attachment 356324 [details] [diff] [review]
don't assume that mac works

this is what nsPrivateBrowsingService.js already does
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-01-11 22:30:30 PST
The patch in bug 462478 would make this one simpler.
Comment 10 Dão Gottwald [:dao] 2009-01-12 17:22:03 PST
Created attachment 356633 [details] [diff] [review]
updated (checked in)
Comment 11 Mike Connor [:mconnor] 2009-01-12 21:36:10 PST
Comment on attachment 356633 [details] [diff] [review]
updated (checked in)

thanks!
Comment 13 Mike Connor [:mconnor] 2009-04-06 09:58:48 PDT
This is "fine" for now, but we should stay on top of this for .next
Comment 14 Mike Beltzner [:beltzner, not reading bugmail] 2009-09-09 12:36:16 PDT
Connor, this is blocking, but there's a checked in patch? I think we want to:

 - close this bug
 - open a new bug with a description of what has to change
 - make that bug blocking, if you believe it needs to be
 - make sure that bug has an assignee

Assigning this to mconnor for now to handle.
Comment 15 Johnathan Nightingale [:johnath] 2009-10-20 13:28:29 PDT
After further discussion with mconnor - this doesn't block. mconnor does still believe we should fix it, instead of just assuming broken z order everywhere except windows. It may well belong in its own bug instead of here, but either way, marking it blocking-.
Comment 16 Henrik Skupin (:whimboo) 2011-09-27 01:58:11 PDT
while on Mac it is working it still fails on Linux. Is there anything we can do here to get this enumerator fixed?
Comment 17 Henrik Skupin (:whimboo) 2013-07-08 06:08:23 PDT
Looks like this is working now across platforms. Ehsan, can you verify that?
Comment 18 :Ehsan Akhgari (out sick) 2013-07-08 06:15:28 PDT
The code in question doesn't exist any more.
Comment 19 Dão Gottwald [:dao] 2013-07-08 07:32:18 PDT
It still exists. (See the URL field.)
Comment 20 :Ehsan Akhgari (out sick) 2013-07-08 09:58:03 PDT
Oh, right, it was moved... by me! ;-)
Comment 21 Henrik Skupin (:whimboo) 2013-07-08 10:08:49 PDT
What I wanted to say in comment 17 is that we have a test for Mozmill which makes use of the getZOrderDOMWindowEnumerator and works well across platforms. So I wonder if those remaining ifdef declarations are still necessary.
Comment 22 Mark Hammond [:markh] 2013-08-28 16:02:35 PDT
According to bug 874566, the ZOrder enumerator now works on Mac, so updating this accordingly.
Comment 23 Dão Gottwald [:dao] 2013-08-28 23:18:08 PDT
(In reply to Mark Hammond (:markh) from comment #22)
> According to bug 874566, the ZOrder enumerator now works on Mac, so updating
> this accordingly.

Please continue that discussion in bug 450576. Once resolved, we should update this bug, and file a bug on updating our BROKEN_WM_Z_ORDER logic.
Comment 24 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-09-06 22:48:40 PDT
This bug doesn't seem useful anymore.
Comment 25 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-09-06 22:52:12 PDT
I morphed bug 891194 into being about fixing BROKEN_WM_Z_ORDER

Note You need to log in before you can comment on or make changes to this bug.