memory leaks from tracemonkey merge Mon Oct 27 20:18:42 2008 -0700

VERIFIED FIXED in mozilla1.9.1b2

Status

()

Core
JavaScript Engine
--
critical
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: karlt, Assigned: dvander)

Tracking

({mlk, regression, verified1.9.1})

Trunk
mozilla1.9.1b2
mlk, regression, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

http://graphs.mozilla.org/graph.html#show=395139,395141,395170,1431037&sel=1225153291,1225173524

http://graphs.mozilla.org/graph.html#type=series&show=2207650

http://tinderbox.mozilla.org/showbuilds.cgi?tree=Firefox&maxdate=1225165355&legend=0&norules=1

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=Oct+27+2008+18%3A00&enddate=Oct+27+2008+21%3A30
Flags: blocking1.9.1?

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Comment 1

9 years ago
I'm worried that Karl's second link shows heap growth over time.
(Assignee)

Comment 2

9 years ago
Created attachment 346091 [details] [diff] [review]
fix for a memory leak
[Checkin: Comment 3 & 11]

Not sure if there's more, this came up from valgrinding.
Attachment #346091 - Flags: review?(gal)

Updated

9 years ago
Attachment #346091 - Flags: review?(gal) → review+
(Assignee)

Comment 3

9 years ago
Pushed fix as changeset: http://hg.mozilla.org/tracemonkey/rev/e24a2e8fc744
(Reporter)

Comment 4

9 years ago
Looks like that's probably the leak, thank you:

http://graphs-stage.mozilla.org/graph.html#type=series&show=430167

(Still a slight increase over time but I suspect that was there before.)
Attachment #346091 - Attachment description: fix for a memory leak → fix for a memory leak [Checkin: Comment 3]
Blocks: 462937
(In reply to comment #4)
> Looks like that's probably the leak, thank you:

I don't know what this patch fixed,

> (Still a slight increase over time but I suspect that was there before.)

but major bug 462937 isn't fixed yet...
(Reporter)

Updated

9 years ago
Attachment #346091 - Attachment description: fix for a memory leak [Checkin: Comment 3] → fix for a memory leak [pushed to tracemonkey: Comment 3]
(Reporter)

Comment 6

9 years ago
Serge, you'll need to use a tracemonkey build or apply the patch yourself to hg-central.

Setting Target Milestone in an attempt to request that this is fixed for Beta2.
Is another tracemonkey merge planned?
Target Milestone: --- → mozilla1.9.1b2

Comment 7

9 years ago
We are waiting for m-c to go green so we can merge.
(Reporter)

Updated

9 years ago
OS: Linux → All
(In reply to comment #6)
> Serge, you'll need to use a tracemonkey build

Oh ! I hadn't noticed that :-<

> Is another tracemonkey merge planned?

I can't understand this was allowed to stay in the tree for days, without even a warning (either manual or automatic), afaict :-(

(Looking forward for the merge !)
Assignee: general → danderson
Severity: normal → critical
Status: NEW → ASSIGNED
Keywords: regression
Hardware: PC → All
(Assignee)

Comment 9

9 years ago
I can't push to m-c -- if the merge doesn't happen soon enough someone can cherry pick the patch.
Comment on attachment 346091 [details] [diff] [review]
fix for a memory leak
[Checkin: Comment 3 & 11]

"approval1.9.1b2=?":
per comment 9; fixes (major) "leak"; is already in tracemonkey repo, should be no risk.
Attachment #346091 - Flags: approval1.9.1b2?
Comment on attachment 346091 [details] [diff] [review]
fix for a memory leak
[Checkin: Comment 3 & 11]

Merged to trunk as part of
rsayre@mozilla.com  Sat Nov 08 01:06:43 2008 -0800
(http://hg.mozilla.org/mozilla-central/rev/17747605490c)
Attachment #346091 - Attachment description: fix for a memory leak [pushed to tracemonkey: Comment 3] → fix for a memory leak [Checkin: Comment 3 & 11]
Attachment #346091 - Flags: approval1.9.1b2?
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081108 Minefield/3.1b2pre] (home, optim default) (W2Ksp4)

V.Fixed, per bug 462937.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Depends on: 465218

Updated

9 years ago
Flags: in-testsuite-
Flags: in-litmus-
Keywords: fixed1.9.1

Updated

9 years ago
Keywords: verified1.9.1
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.