Last Comment Bug 462983 - always calculate extra states
: always calculate extra states
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: alexander :surkov
Mentors:
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2008-11-03 20:15 PST by alexander :surkov
Modified: 2011-06-08 18:30 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description alexander :surkov 2008-11-03 20:15:24 PST
1) we will do this eventually, see bug 344674
2) I need this to fix the bug 434707 because extra states should be passed into GetARIAState and they must be calculated at that point
Comment 1 Aaron Leventhal 2008-11-05 08:30:07 PST
I wonder if this will make perf worse for some ATs.

Maybe not for newer ones though, which are the ones we care about.
Comment 2 alexander :surkov 2008-11-27 05:43:45 PST
(In reply to comment #1)
> I wonder if this will make perf worse for some ATs.
> 
> Maybe not for newer ones though, which are the ones we care about.

Now states affect on extra states. bug 434707 requires to make reverse dependence. So we need to compute extra states to finish states computing. If you care about performance then we shouldn't calculate all states together if we want to get one state and therefore we should have separate methods for every state (or something like).
Comment 3 Aaron Leventhal 2008-12-01 01:50:23 PST
Okay.
Comment 4 Trevor Saunders (:tbsaunde) 2011-06-08 18:00:11 PDT
We know always calculate all states, just don't allways give all of them to js.
Comment 5 alexander :surkov 2011-06-08 18:30:08 PDT
(In reply to comment #4)
> We know always calculate all states, just don't allways give all of them to
> js.

When you mark fixed then please point what is a fix. 

Fixed by bug 634218.

Note You need to log in before you can comment on or make changes to this bug.