Save to Disk has no choose dir in "Download" [new pick app] dialog (no file picker appears)

VERIFIED DUPLICATE of bug 47248

Status

SeaMonkey
UI Design
P3
critical
VERIFIED DUPLICATE of bug 47248
18 years ago
7 years ago

People

(Reporter: laurel, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Using july24 commercial build NT 4.0

There is no choose button associated with Save to Disk in the mime type
application "Downloading" dialog.  There is a choose button associated with the
"Open using" option, that button disables when Save to Disk is selected (however
the button still works to open a dialog).

1.  View a page in browser or a mail message containing a link such as 
http://client/seamonkey/launch/reviewers_guide/master_pr2.doc
2.  Click on the link.
3.  In the resulting "downloading" dialog, click the option Save to Disk. Note
there is no option to choose where on disk you wish to place the saved file.

Comment 1

18 years ago
yep, I see that on 072408 mozilla win32 bits. XPApps GUI Features I think.
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
Summary: Save to Disk has no choose dir in "Downloading" dialog. → Save to Disk has no choose dir in "Downloading" dialog.
aha...this is likely what i encountered when fiddling with bug 44176.

i sadly doubt this'll get fixed for beta2, so relnote2. augh.

bill, does this belong to you, or should it remain ben's?
Assignee: ben → law
Keywords: dogfood, relnote2
Keywords: nsbeta2, nsbeta3
Severity: normal → major
was able to repro this on linux [branch, comm 2000.08.31.04-m17] with these
steps:

1. go to http://www.mozilla.org
2. in the Nightly Build section, click the Macintosh link (the other ones will
result in the Unknown File Type dialog --what's the bug for that?).
3. in the resulting Download dialog, click the option Save to Disk. note
there is no option to choose where on disk you wish to place the saved file.
OS: Windows NT → All
Hardware: PC → All
Summary: Save to Disk has no choose dir in "Downloading" dialog. → Save to Disk has no choose dir in "Downloading" dialog
after doing the above steps on the Mac the Download dialog only shows the
widgets --*no* text-- and downloading begins immediately (you're not given a
choice).

upping to critical. anyone else see this?
Severity: major → critical
i've filed bug 47240 for the Mac weirdness i saw [my comments at 2000-08-01
16:36 ].
Summary: Save to Disk has no choose dir in "Downloading" dialog → Save to Disk has no choose dir in "Download" [new pick app] dialog

Comment 6

18 years ago
Putting on [nsbeta2+] radar.
Whiteboard: [nsbeta2+] Investigating....
Depends on: 47358
(Assignee)

Updated

18 years ago
No longer depends on: 47358

Comment 7

18 years ago
We found that this occurs on all platforms *and* if you do the following
[quickly!] *before* the progress meter in the statusbar (bug 44176) has
completed downloading:

1. select the Save to Disk radiobutton
2. click OK

result: no file picker will appear.

expected: downloading shouldn't be so fragile as to not allow the user to change
her/his mind as to where to download a file. :-)
Depends on: 44176
Summary: Save to Disk has no choose dir in "Download" [new pick app] dialog → Save to Disk has no choose dir in "Download" [new pick app] dialog (no file picker appears)
Whiteboard: [nsbeta2+] Investigating.... → [nsbeta2+]
(Assignee)

Comment 8

18 years ago
I'm consoldating a bunch of bugs which are all related. Looks like the helper
app dialog issues a cancel even when it gets unloaded. This causes us to cancel
the load. 
Assignee: law → mscott
(Assignee)

Comment 9

18 years ago
this is now a dup of 47248.

*** This bug has been marked as a duplicate of 47248 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
vrfy dup.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.