Last Comment Bug 463154 - Form history should record creation/usage timestamps.
: Form history should record creation/usage timestamps.
Status: RESOLVED FIXED
: fixed1.9.1, verified1.9.0.9
Product: Toolkit
Classification: Components
Component: Form Manager (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla1.9.1b2
Assigned To: Justin Dolske [:Dolske]
:
: Matthew N. [:MattN] (PM if requests are blocking you)
Mentors:
Depends on: 464858 472064
Blocks: 243136 464947 483096
  Show dependency treegraph
 
Reported: 2008-11-04 17:41 PST by Justin Dolske [:Dolske]
Modified: 2012-12-09 05:37 PST (History)
8 users (show)
mbeltzner: blocking1.9.1+
dolske: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v.1 (WIP) (19.86 KB, patch)
2008-11-05 00:59 PST, Justin Dolske [:Dolske]
no flags Details | Diff | Splinter Review
Patch v.2 (37.99 KB, patch)
2008-11-06 17:24 PST, Justin Dolske [:Dolske]
mconnor: review+
sdwilsh: review+
Details | Diff | Splinter Review
formhistory.sqlite which breaks search bar (4.00 KB, application/octet-stream)
2009-01-04 10:53 PST, Henrik Skupin (:whimboo) [away 02/18 - 02/27]
no flags Details

Description User image Justin Dolske [:Dolske] 2008-11-04 17:41:42 PST
Form history entries should be stored with a timestamp indicating when they were last used. This is needed for a few features of interest:

1) "Forget everything I did in the last hour"
2) Enable expiring old form history automatically
3) Awesomebar-like functionality for form fields could use this for frecency.

The first step to these features is storing the timestamps... #2 and #3 would want a last-used timestamp. #1 would need a when-created timestamp (we wouldn't want to clear out pre-existing entries)
Comment 1 User image Justin Dolske [:Dolske] 2008-11-05 00:59:40 PST
Created attachment 346414 [details] [diff] [review]
Patch v.1 (WIP)

Compiles but completely untested.
Comment 2 User image Justin Dolske [:Dolske] 2008-11-06 17:24:15 PST
Created attachment 346791 [details] [diff] [review]
Patch v.2
Comment 3 User image Shawn Wilsher :sdwilsh 2008-11-10 19:21:55 PST
Comment on attachment 346791 [details] [diff] [review]
Patch v.2

r=sdwilsh
Comment 4 User image Justin Dolske [:Dolske] 2008-11-13 10:35:56 PST
Pushed changeset b02a1924b231.
Comment 5 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2009-01-04 10:53:58 PST
Created attachment 355312 [details]
formhistory.sqlite which breaks search bar

Justin, today I got a notice from a friend that his search bar isn't working anymore with Firefox 3.0.5 after he accidentally selected a profile for a test with Firefox 3.2a1. After some tests we identified the formhistory.sqlite to be the cause for the problem and reduced this database to a minimized test case. Now it only contains one single entry. I tested Firefox 3.1 with this formhistory.sqlite and it works fine after this patch was checked into the tree between 081113 and 081114.

Is there any way to get this into the 1.9.0 branch too? This patch looks a bit too heavy, so I wanted to ask you first before filing a new bug on that. What do you think?
Comment 6 User image Justin Dolske [:Dolske] 2009-01-04 13:51:48 PST
Yeah, known problem, but I haven't filed the bug. :(

Satchel needs the same DB upgrade/downgrade logic as bug 467463 adds for pwmgr, and the column shouldn't be created with "NOT NULL".
Comment 7 User image Justin Dolske [:Dolske] 2009-01-04 14:01:21 PST
(filed bug 472064)
Comment 8 User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2009-03-13 03:38:16 PDT
Justin, even with bug 472064 fixed the formhistory.sqlite from my comment 5 breaks the search bar with Firefox 3.0.7 on OS X. Shouldn't that have been fixed?
Comment 9 User image Justin Dolske [:Dolske] 2009-03-13 13:11:59 PDT
No, that's expected but not fixable.

Profiles created with 3.1/3.2 builds between when this bug landed (Nov 11) and when bug 472064 landed (Jan 22) will have formhistory files unusuable with Firefox 3.0. See bug 472064 comment 5.
Comment 10 User image Justin Dolske [:Dolske] 2009-03-17 15:04:22 PDT
This fix landed on 1.9.0.8 as part of bug 483096.
Comment 11 User image Al Billings [:abillings] 2009-03-19 16:55:13 PDT
Verified through bug 483096 for 1.9.0.8.

Note You need to log in before you can comment on or make changes to this bug.