Closed Bug 463246 Opened 11 years ago Closed 11 years ago

Confirm EULAs when installing add-ons from collections

Categories

(addons.mozilla.org Graveyard :: Collections, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wenzel, Assigned: wenzel)

References

Details

When installing add-ons from the collections page, we need to have all applicable EULAs confirmed by the user before the installation happens. If a EULA is not accepted, the add-on won't be installed.

Boriss made a wireframe for it on grouphub already.
Boriss: Is there a chance to integrate the EULAs into the "shopping cart" list, without adding a second step for the EULA confirmations? Or would that be overwhelming and thus be bad UX?
This is implemented in r19537. I showing the EULA with JavaScript, and only if it is confirmed will the respective add-on be installed. I CSSed the EULA text so it is scrollable and looks pleasant (I hope).

Marking this closed, but if any of this is not working as intended, please reopen.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED; David/Boriss: I filed bug 463357 as an RFE.
Status: RESOLVED → VERIFIED
For the record - the approach I think would be best for the user here would be for the user to agree to all EULAs at once  and be able to view them at once as a collated text document from the dropdown.  It was discussed here ( https://mozilla.grouphub.com/projects/2243134/posts/17549516/comments#25580203 ), but David pointed out that we don't have time for such a change at this point.
Has been pushed live last night.
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.