Closed Bug 463282 Opened 11 years ago Closed 11 years ago

Tasks cannot be created or imported

Categories

(Calendar :: Provider: Local Storage, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: dbo)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081105 Calendar/1.0pre (BuildID: 20081105110610)

Steps to Reproduce:
1. Start Sunbird with clean profile
2. Import the attached testcase that was taken from Bug 383462

Actual Results:
Import fails. Console shows:
********** mozStorageStatementWrapper: Couldn't find parameter :event_stamp

Alert dialog shows:
1 items failed to import. The last error was: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calICalendar.addItem]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/import-export.js :: putItemsIntoCal :: line 191"  data: no]

Additional Information:
Works in Sunbird 0.7 ... Sunbird 0.9, fails in Sunbird 1.0pre -> regression
Error can also be reproduced by using the following steps:
1. Create new task
2. Set it to repeat daily
3. Try to save tasks
Component: General → Provider: Local Storage
Flags: blocking-calendar1.0?
QA Contact: general → storage-provider
Summary: Import of VTODO with RRULE but no DTSTART fails → Repeating tasks cannot be created or imported
Severity: normal → major
Regression range: Works in Sunbird 1.0pre (20081104050504)
                  Fails in Sunbird 1.0pre (20081105034730)

Seems to be regressed by Bug 457203.
Blocks: 457203
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Attached patch fix - v1Splinter Review
Attachment #346646 - Flags: review?(philipp)
Flags: in-testsuite?
There seems to be an issue with opening the upgrade profile (with database schema 15) in a previous build. I get the expected "Upgraded ... data incompatible ... Sunbird will quit" dialog. But in the background Sunbird uses 100% of CPU and hangs the system. Trying to close the Quit-dialog has no effects. The Sunbird process had to be killed via Task-Manager.
Summary: Repeating tasks cannot be created or imported → Tasks cannot be created or imported
Duplicate of this bug: 463840
Comment on attachment 346646 [details] [diff] [review]
fix - v1

Must DTSTAMP not be set quite late in the game, similar to LAST-MODIFIED?

r=philipp with question considered
Attachment #346646 - Flags: review?(philipp) → review+
Comment on attachment 346646 [details] [diff] [review]
fix - v1

requesting 2nd review due to schema change
Attachment #346646 - Flags: review?(Berend.Cornelius)
(In reply to comment #4)
Stefan, could you please file follow-up bug for that?


(In reply to comment #6)
> Must DTSTAMP not be set quite late in the game, similar to LAST-MODIFIED?
It's not necessary. The "init-as-is-without-modification" is just tied to setting the LAST-MODIFIED property.
Duplicate of this bug: 464347
Attachment #346646 - Flags: review?(Berend.Cornelius) → review+
Comment on attachment 346646 [details] [diff] [review]
fix - v1

looks good; r=berend.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/8beded258a4b>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Does this mean it has been fixed in the nightly builds of lightning using Thunderbird 3.01b pre?
-> VERIFIED

build 20081112060034 (Win + Mac)

re#12 yes, it does
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.