RFE: add an unique id for each contact to nsIABCard (creation date?)

RESOLVED DUPLICATE of bug 444093

Status

--
enhancement
RESOLVED DUPLICATE of bug 444093
10 years ago
10 years ago

People

(Reporter: intendentedelleacque, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17
Build Identifier: 

I think it could be useful to have available a unique and persistent id for each contact in addressbook; this could help a lot in linking photo, contacts syncronization etc.
Maybe it could be simply adding a "creationDate" property in nsIABCard, with the timestamp of the creation of the contact, it should be sufficient for this puropose.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444093
You need to log in before you can comment on or make changes to this bug.