Icon and preview image for default theme missing in add-on manager

VERIFIED FIXED in 1.0b1

Status

Calendar
Sunbird Only
--
minor
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b1
regression

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Created attachment 346963 [details]
screenshot

The icon and preview image for Sunbird default theme are missing in add-on manager, see screenshot.

Regression range: Works in Sunbird 1.0pre (20081021035436)
                  Fails in Sunbird 1.0pre (20081022032438)

Most probably regressed by Bug 290747.
(Assignee)

Comment 1

10 years ago
Created attachment 346981 [details] [diff] [review]
Fix - v1

This fixes.

it seems that "classic.jar" can contain the icon and preview for the default theme, but the way extensions do it is to put the files in the root of the theme. I'm going with the latter solution since it also works and seems more consistant.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #346981 - Flags: review?(daniel.boelzle)

Comment 2

10 years ago
Comment on attachment 346981 [details] [diff] [review]
Fix - v1

r=dbo
Attachment #346981 - Flags: review?(daniel.boelzle) → review+
(Assignee)

Comment 3

10 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f49e757f1f93>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 4

10 years ago
Created attachment 347516 [details] [diff] [review]
Fix packages-static/removed-files.in

r=dbo over the shoulder, this takes care of removing the classic.jar from existing installs.

QA: Some update testing would be nice :-)
Attachment #347516 - Flags: review+
(Assignee)

Comment 5

10 years ago
Extra fixed pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a5f811d59d97>
(Reporter)

Comment 6

10 years ago
Why is classic.jar obsolete? Doesn't it contain all the toolkit styles and images?
(Assignee)

Comment 7

10 years ago
You are right, sorry about that. I'll back out that change.
(Assignee)

Comment 8

10 years ago
backout changeset is 13e258959c0e
(Reporter)

Comment 9

10 years ago
Issue still exists using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Calendar/1.0pre (BuildID: 20081112033628).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

10 years ago
Created attachment 347783 [details] [diff] [review]
fix packages-static
Attachment #347516 - Attachment is obsolete: true
Attachment #347783 - Flags: review?(philipp)
(Assignee)

Comment 11

10 years ago
Comment on attachment 347783 [details] [diff] [review]
fix packages-static

Ah yes, thanks. packages-static always gets me off track :-}

r=philipp
Attachment #347783 - Flags: review?(philipp) → review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/719722181ac9>

-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 13

10 years ago
Checked in sunbird buils 20081112 -> VERIFIED.
Status: RESOLVED → VERIFIED

Comment 14

10 years ago
Seems to be guilty for bug 465048 ?!
(Assignee)

Comment 15

7 years ago
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.