Closed Bug 290747 Opened 15 years ago Closed 11 years ago

use sunbird.jar for sunbird specific files

Categories

(Calendar :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mvl, Assigned: Fallen)

References

Details

(Keywords: mail-integration)

Attachments

(4 files, 2 obsolete files)

The current way of everwriting files in calendar.jar for sunbird is painful if
you rebuild, and you forget to rebuild in sunbird.
I suggest to use sunbird.jar for sunbird specific files.
Attached patch work in progress v1 (obsolete) β€” β€” Splinter Review
patch creates sunbird.jar. so far seems to work.
I need to firust out theming.
Also, the commandlineHandling needs to be moved and changed. Still working on
that.
QA Contact: gurganbl → sunbird
*** Bug 292771 has been marked as a duplicate of this bug. ***
This should be significantly easier with the dropping of the XPI, the move of locales to /l10n, and all the cleanup.

nominating for 0.3

mvl: I'm willing to take this over if you'd like
Flags: blocking0.3?
Nice to have, but we wouldn't hold a release for this.
Flags: blocking0.3? → blocking0.3-
-> lilmatt
Assignee: mvl → mattwillis
taking
Status: NEW → ASSIGNED
Assignee: lilmatt → nobody
Status: ASSIGNED → NEW
Component: Sunbird Only → Build Config
QA Contact: sunbird → build
mvl, could you please provide an updated status on your patch/bug?
Nothing really changed since I posted the patch (which is now hopelessly bitrotted). So there is no status to give an update to.
Attached patch Step 1 - Move around files (obsolete) β€” β€” Splinter Review
I'd like to do this in two steps to not break too much at once. This step takes care of the following:

* Most jar manifests:
  - Align bracketed values at column 60
  - Replace #expand with #filter substitution and @THEME@
  - get rid of classic/ part, I believe this was done for historic reasons
* Move sunbird/themes/@THEME@/sunbird/ to sunbird/base/themes/@THEME@/
  - Get rid of unneeded Makefile.in's, LICENSE file and contents.rdf's
  - Generalize jar.mn's from sunbird/themes/@THEME@/sunbird/jar.mn to
    sunbird/base/jar.mn
* Move aboutDialog.* to chrome://sunbird/ 
  - adds locales/en-US/chrome/sunbird
  - adds sunbird.jar and sunbird-@AB_CD@.jar
* Get rid of Throbber.png/gif and synch_animated.gif
  - replace winstripe throbber with toolkit throbber images
* Fit packages-static for new jar files
Assignee: nobody → philipp
Attachment #180989 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #342786 - Flags: review?(daniel.boelzle)
Comment on attachment 342786 [details] [diff] [review]
Step 1 - Move around files

Stefan, it would be nice if you could also take a look since you know a lot about jar files and packaging.

Anyone else is also welcome to doublecheck
Attachment #342786 - Flags: review?(ssitter)
This step takes care of moving parts of files out into their sunbird counterpart. Its not necessarily complete (i.e I could move out a bunch of lightning-specific strings into files only packaged with lightning), but it takes care of the most obvious things:

* Move sb specific toolbar css rules into chrome://sunbird/skin/toolbar.css
* Move sb specific entities from calendar.dtd into sunbird.dtd 
  - I've changed the entity names here from calendar.... to sunbird....
* Move sb specific entities from calendar/locale/menuOverlay.dtd into
  sunbird/locale/menuOverlay.dtd
* More jar.mn aligning I forgot to put in Step 1

Step 2 obviously requires Step 1 to be applied (thank you, mq!!)
Attachment #342793 - Flags: review?(daniel.boelzle)
Attachment #342793 - Flags: review?(Berend.Cornelius)
Attachment #342793 - Flags: review?(daniel.boelzle) → review?(mschroeder)
Fixing this bug makes packaging easier since the UI for thunderbird is going in a different direction than the current UI for Sunbird is.
Flags: tb-integration?
Flags: tb-integration?
Note this bug calls for patches for domi and venkman to fit with the new main window uri for Sunbird. I'll take care when these are checked in and don't cause problems.
Comment on attachment 342786 [details] [diff] [review]
Step 1 - Move around files

From a very, very quick look at the patch:

+ skin/calendar/timezone_10h30.png  (/calendar/prototypes/themes/@THEME@/timezone_10h.png)
+ skin/calendar/timezone_10h.png    (/calendar/prototypes/themes/@THEME@/timezone_10h.png)
+ skin/calendar/timezone_11h30.png  (/calendar/prototypes/themes/@THEME@/timezone_11h.png)
+ skin/calendar/timezone_11h.png    (/calendar/prototypes/themes/@THEME@/timezone_11h.png)
+ skin/calendar/timezone_12h45.png  (/calendar/prototypes/themes/@THEME@/timezone_12h.png)
+ skin/calendar/timezone_12h.png    (/calendar/prototypes/themes/@THEME@/timezone_12h.png)
+ skin/calendar/timezone_13h.png    (/calendar/prototypes/themes/@THEME@/timezone_13h.png)
+ skin/calendar/timezone_14h.png    (/calendar/prototypes/themes/@THEME@/timezone_13h.png)

Wrong images used

+DEFINES += \
+    -DAPP_VERSION="$(APP_VERSION)" \
+	-DTHEME=$(THEME) \
+	$(NULL)

Tabs vs. spaces?
(In reply to comment #14)
...
> + skin/calendar/timezone_13h.png   
> (/calendar/prototypes/themes/@THEME@/timezone_13h.png)
> + skin/calendar/timezone_14h.png   
> (/calendar/prototypes/themes/@THEME@/timezone_13h.png)
> 
> Wrong images used

I see...strangely enough this was already that way before. Christian, any ideas?

Took care of the tabs issue, thanks.
Comment on attachment 342793 [details] [diff] [review]
Step 2 - Move entities and rules around

Tested both applications and found it was Ok.
r=berend
Attachment #342793 - Flags: review?(Berend.Cornelius) → review+
Comment on attachment 342793 [details] [diff] [review]
Step 2 - Move entities and rules around

r=mschroeder
Attachment #342793 - Flags: review?(mschroeder) → review+
Debitrotted patch
Attachment #342786 - Attachment is obsolete: true
Attachment #343902 - Flags: review?(daniel.boelzle)
Attachment #342786 - Flags: review?(ssitter)
Attachment #342786 - Flags: review?(daniel.boelzle)
Comment on attachment 343902 [details] [diff] [review]
Step 1 - Move around files - v2

r=dbo
Attachment #343902 - Flags: review?(daniel.boelzle) → review+
Pushed to comm-central

Step 1: <http://hg.mozilla.org/comm-central/rev/afd7891715ee>
Step 2: <http://hg.mozilla.org/comm-central/rev/fdea86912f93>

I decided to check in the two side by side, I'll take care of breakages if they show up.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
I'm checking in this additional fix, without it the sunbird customize toolbar dialog is borked.
Blocks: 461006
Depends on: 461328
Depends on: 462426
Depends on: 463716
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.