"Import everything" from Mail & Newsgroup window and "Import" from Bookmark Manager result in Page Load Error

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

({regression})

Trunk
regression
Bug Flags:
blocking-seamonkey2.0a2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081108 SeaMonkey/2.0a2pre

Clicking Next in the dialog that can be reached from MailNews Tools/Import (with the default option "Import everything" active) results in a window that only consists of a title that says "Page Load Err...". The rest can only be seen when you maximize the window (which you have to do via the context menu on Windows, double clicking doesn't work here). [The broken window itself is worth another bug.] The contents (on my computer) are:

"File Not Found
The file jar:file:///E:/Programme/seamonkey/chrome/comm.jar!/content/communicator/migration/migration.xul cannot be found. Please check the location and try again."

I guess the problem is in suite/profile/migration/jar.mn which seems to point to the wrong location. I guess the fix is as simple as using the same syntax as source/mail/components/migration/jar.mn, i.e. with leading asterisk and (in our case) the file names in parenthesis at the end (we have the files in suite/profile/migration/ while TB has them in mail/components/migration/content/).

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081107 SeaMonkey/2.0a2pre

This bug is reproducible in trunk.

It's work fine on Thunderbird trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2.0a2?

Updated

10 years ago
Summary: Import everything results in Page Load Error → "Import everything" from Mail & Newsgroup window results in Page Load Error
(Reporter)

Comment 2

10 years ago
The Bookmark Manager (Tools/Import) is also affected.
Summary: "Import everything" from Mail & Newsgroup window results in Page Load Error → "Import everything" from Mail & Newsgroup window and "Import" from Bookmark Manager result in Page Load Error
(Reporter)

Comment 3

10 years ago
Created attachment 348279 [details] [diff] [review]
process migration jar.mn

By trying different things I found that the real problem seems to be that the jar.mn is not processed at all. Adding a simple Makefile.in in the migration/ folder and adding "migration" to PARALLEL_DIRS of the Makefile.in one level above seems to be all that needs to be done. The jar.mn file doesn't even need to be changed.

I'm not sure whether I should put my name in the Makefile.in so feel free to change it to standard8 if that's all that needs to be done. I'm more interested in knowing whether this is already the minimal set of changes. I'd also like someone else to actually compile this before requesting sr if this gets r+. The attached patch works for me (fixes both MailNews and Bookmark Manager Import) though.
Attachment #348279 - Flags: review?(bugzilla)
I'm actually tempted to say that rather than recreating the Makefile.in in suite/profile/migration, we should just move the jar.mn to the directory above, i.e. suite/profile (with appropriate modifications). It will then be processed due to the Makefile.in in suite/profile and we won't need to enter an additional directory, which is part of what bug 462736 was stopping us from doing.
Blocks: 462736
Keywords: regression

Comment 5

10 years ago
D'oh. How silly of me.

I'm not keen on Mark's idea, so here are two suggestions of my own:

We could just move all three affected files into profile/

Or we could move the xul into common/migration and tweak its jar.mn
I'm fine on either of those.

Comment 7

10 years ago
I think we should either move the jar.mn to profile/ as Mark suggested or the XUL to common/
Flags: blocking-seamonkey2.0a2? → blocking-seamonkey2.0a2+
Comment on attachment 348279 [details] [diff] [review]
process migration jar.mn

Per current discussions on this bug.
Attachment #348279 - Flags: review?(bugzilla) → review-

Comment 9

10 years ago
Also occurs w/linux using Ubuntu 8.10 (kernel 2.6.27-8-generic) from:

http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
seamonkey-2.0a2pre.en-US.linux-i686.tar.bz2
19-Nov-2008 01:05 13M

Comment 10

10 years ago
Mark, Neil, can we reach some conclusion on what to do here? The a2 freeze is nearing and this is definitely a blocker.

Comment 11

10 years ago
> We could just move all three affected files into profile/

Since hg can move files and keep history isn't this the simplest?
Comment on attachment 350538 [details] [diff] [review]
Moves

Not sure who you feel comfortable reviewing, but per bug and reading patch r+... I suppose this is the best
Attachment #350538 - Flags: review+
Attachment #350538 - Flags: review? → review+

Comment 14

10 years ago
Pushed changeset 5b0a3aaaf950 to comm-central.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 15

10 years ago
Confirmed working.

Tested on Ubuntu 8.10 (Intrepid): 
seamonkey-2.0a2pre.en-US.linux-i686.tar.bz2  	13276 KB  	11/30/2008  	02:23:00 AM
from:
ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/tinderbox-builds/comm-central-linux/1228011443/

Works. Thanks!
You need to log in before you can comment on or make changes to this bug.