Closed Bug 463971 Opened 11 years ago Closed 11 years ago

Shredder Import dialog is blank instead of showing import results as with Thunderbird 2.0.0.x

Categories

(Thunderbird :: Migration, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b1

People

(Reporter: fehe, Assigned: philor)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081109 Shredder/3.0b1pre ID:20081109031120

When importing email from Outlook Express, Shredder should be showing the import results in the "Import" dialog that remains while import is occurring.  This is the Thunderbird 2.0.0.x behavior.  With Shredder, the dialog is completely blank--with the exception of the progress bar.


Reproducible: Always

Steps to Reproduce:
1. Make sure you have messages in Outlook Express
2. Launch Shredder and click Tools -->Import -->Mail.  Click Next
3. Notice that the "Import" dialog is completely blank--with the exception of the progress bar while importing.
4. Compare the above with 2.0.0.17

Actual Results:  



Expected Results:  
Behavior should be as with Thunderbird 2.0.0.17
Keywords: regression
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081031 Shredder/3.0b1pre
Exactly its empty and no button finish, folders are imported but not messages.
Status: UNCONFIRMED → NEW
Ever confirmed: true
@Nikolay: The message content import bug was fixed by Bug 455229.  I notice your build is from October 31.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081110 Shredder/3.0b1pre
Now importing completes with blank dialog box as reported.
Hmm, missing text, you say?
Yeah, no text and button finish is unavailable only cancel - which do nothing because everything already done :)
(In reply to comment #4)
> Hmm, missing text, you say?

Compare with 2.0.0.17
Flags: wanted-thunderbird3?
Some times, you have to look at my bug comments in context, like when I say "Hmm, missing text, you say?" at the same time that I cc the author of a patch which removed a great many strings that we thought and hoped were unused.
> a patch
> which removed a great many strings that we thought and hoped were unused.
hmm so probably missing text when trying to import from Outlook which is not set as a default e-mail client does also apply to this action (didn't file this one yet).
Can someone please check, whether re-adding the strings removed from importMsgs.properties in attachment 345908 [details] [diff] [review] fixes this?

If that is the case, then can someone please tell me, why the hell we reference strings directly in .h and .cpp files? How is a typical localizer ever supposed to test this?
JS, actually: http://mxr.mozilla.org/comm-central/source/mailnews/import/resources/content/importDialog.js#469 looking for the "Import" + "Mail" + "Success" (or "Failed") that we both somehow decided was unused even while we left the "Address" and "Filters" and "Settings" variants, would explain the blank at the end.

However, comment 0 seems to be saying that the MailProgressMeterText string isn't showing up during import, which I don't understand since MailProgressTitle was all we removed, and it really does look unused. IU, Nikolay: do you mean only blank at the end, but you do see the "Converting mailboxes from Outlook Express" text during the import, or that you don't see the "Converting" string either?
(In reply to comment #11)
> IU, Nikolay: do you mean only blank at the end, but you do see the "Converting
> mailboxes from Outlook Express" text during the import, or that you don't see
> the "Converting" string either?

The "Converting" string is present, but everything else above that, showing activity, is not present.  And once done, the dialog is completely blank--except for the title and buttons.

And as Nikolay pointed out, there is no "Finish" button--only "Cancel"
IU: What string do you see above the "Converting" string in 2.x while doing Tools - Import - Mail (as in, the exact words so I can search for the string)?

If I delete all profiles to get the first-run "import everything" in 2.x, I see a list for "The following items are currently being imported..." in the upper part of the wizard pane, that then lists Settings, Address Book, and Mail as they are imported, but with Tools - Import - Mail all I see is the "Converting" string at the bottom, just above the progress bar.
@Phil: Oops.  You're right.  I'm confusing those two.

With 2.0.0.17, the Tools -->Import -->Mail option shows only a summary at the end, indicating, "Mail was successfully imported from Outlook Express", accompanied by a list of the mailboxes imported and the number of messages imported from each.  The "Next" button becomes the "Finish" button.
Attached patch Fix v.1Splinter Review
Cool, misremembering is way better than another missing string that I couldn't even find :)

For the importDialog.js comment change - never let it be said I'm a sore loser who blames whatever's handy for my screwup. I am, but never let it be said.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #347454 - Flags: superreview?(bugzilla)
Attachment #347454 - Flags: review?(bugzilla)
Flags: wanted-thunderbird3? → blocking-thunderbird3+
Priority: -- → P2
Target Milestone: --- → Thunderbird 3.0b1
Attachment #347454 - Flags: superreview?(bugzilla)
Attachment #347454 - Flags: superreview+
Attachment #347454 - Flags: review?(bugzilla)
Attachment #347454 - Flags: review+
http://hg.mozilla.org/comm-central/rev/8da76691fcc8
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Thanks

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081111 Shredder/3.0b1pre ID:20081111140108
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.