Closed Bug 464102 Opened 11 years ago Closed 11 years ago

When closing Edit Task dialog, it will not prompt to save if only change is which calendar

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: leifarne, Assigned: dbo)

References

Details

(Keywords: dataloss)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nn-NO; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

The Edit Task dialog does not prompt to save the task if the only change is which calendar the task is associated with.

Reproducible: Always

Steps to Reproduce:
Make sure you have multiple calendars.

1. Create and save a task.
2. Open the task.
3. Change which calendar the task is associated with. Do not change anything else.
4. Close the dialog with Alt-F4 or the close button.

Actual Results:  

You are not prompted to save changes, and the previously selected calendar is still associated.

Expected Results:  
A save prompt.
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Lightning/1.0pre Shredder/3.0b1pre
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: tb-integration?
Flags: blocking-calendar1.0?
OS: Linux → All
Hardware: PC → All
Flags: tb-integration? → tb-integration+
Keywords: dataloss
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Attached patch fix - v1Splinter Review
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #349184 - Flags: review?(Berend.Cornelius)
Comment on attachment 349184 [details] [diff] [review]
fix - v1

Shouldn't we add the id-comparison to "compareItemContent()"? Not sure about this.
r=berend
Attachment #349184 - Flags: review?(Berend.Cornelius) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/e1f22abdcb91>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(In reply to comment #3)
> (From update of attachment 349184 [details] [diff] [review])
> Shouldn't we add the id-comparison to "compareItemContent()"? Not sure about
> this.
I don't think so, because that function should only compare two items per "content", not the relation to which calendar they belong.
Checked in lightning and sunbird build 20081123 -> VERIFIED.
Status: RESOLVED → VERIFIED
Does the fix only correlate to changes of the calendar?
I found this bug also when changing start or end date/time. If only one value was changed and the field is still focused when closing the dialog, the change is not recognized. (Lightning 0.9)
(In reply to comment #7)
Datz, you are seeing Bug 392448.
Duplicate of this bug: 364387
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.