Event dialog: 'X' doesn't work for edited events

RESOLVED DUPLICATE of bug 464102

Status

Calendar
Dialogs
RESOLVED DUPLICATE of bug 464102
11 years ago
7 years ago

People

(Reporter: Omar Bajraszewski, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

When you have installed wcap enabler and create an event and press 'x' you are asked if you want to save changes. When you edit an event and change calendar and press 'x' nothing happens

Reproducible: Always

Steps to Reproduce:
1.Create two calendars
2.Create an event
3.Edit an event
4.Change calendar
5.Press 'x'

Actual Results:  
Changes are not saved

Expected Results:  
You're asked if you want to save the changes

When you change 'repeat' pattern and press 'x' you are asked for saving changes


Lightning 2006121903

Updated

11 years ago
Summary: (proto) 'X' doesn't work for edited events → [Proto] Event dialog: 'X' doesn't work for edited events

Comment 1

11 years ago
This problem may exist only in Lightning because Sunbird does not support saving/confirming when 'x' is pressed

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070114 Calendar/0.6a1
Component: Calendar Views → Lightning Only
QA Contact: views → lightning

Comment 2

11 years ago
sorry, I misunderstood your intention - this is duplicate of bug 361993
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: Lightning Only → Calendar Views
Resolution: --- → DUPLICATE
Duplicate of bug: 361993
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> sorry, I misunderstood your intention - this is duplicate of bug 361993
> 
> *** This bug has been marked as a duplicate of bug 361993 ***
> 

I don't agree- it's not the same. My bug report is about prototype. I cannot reproduce the problem described in bug 361993 using prototype. It's not a duplicate. Please reopen it
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

11 years ago
Yes, the prototype event dialog and the normal event dialog are two different animals. These bugs are *not* duplicates.

I can confirm the bug: lightning +wcap (2007012203) in Thunderbird version 2 beta 2 (20070122) on windows XP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

11 years ago
When I opened a prototype new event dialog and pressed 'X' button lightning used to ask me whether I wanted to save changes or not. Now prototype has been updated---> this function doesn't exist anymore. I don't know if it's intentional or not. If it's not intentional I shall leave the bug report open and there should be a new bug report filled (regression). If it's intentional I shall mark it as WFM. What shall I do?
I didn't remove any functionality from the prototype event dialog. So generally, the user gets asked whether or not the changes should be discarded or saved in case the item changed. At least this is how it should work in theory ;-)

But you're right that the question isn't raised if the item is about to be moved to a different calendar. I just tested this and nothing happens, the item won't get moved to the other calendar. Pressing "save and close" indeed moves the item to the other calendar, but closing the dialog does nothing. So, I'd suggest that this bug should be dedicated to this problem.

Of course, there could be other situations where the question whether or not the item should be saved pop up unexpectedly or doesn't get raised at all. I'd suggest that we file new bugs for each encounter of such circumstances.
taking this one.
Assignee: nobody → michael.buettner
I can no longer reproduce this behavior -> WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME

Comment 9

10 years ago
Using Sunbird 0.7pre (20070808) I can still reproduce this issue if using the Escape key to close the dialog. No confirmation dialog is shown. Closing the dialog by clicking the X dialog button shows the confirmation dialog as expected.

Comment 10

10 years ago
I expect this should be reopened if Stefan can reproduce it, right?
Whiteboard: [qa discussion needed]
Escape key & confirmation dialog is WFM using Tb 2.0.0.7pre (20070818) + Lightning 0.7pre (2007081705) on WinXP and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070817 Calendar/0.7pre. Stefan, can you confirm this?

Comment 12

10 years ago
Still fails using Sunbird 0.7pre (2007081806) with the following STR:
1. Create new event in calendar A
2. Edit event and change from calendar A to calendar B
3. Press Escape key -> Confirmation dialog is shown. Save (Press Yes).
4. Edit event and change from calendar B to calendar A (or another one)
5. Press Escape key or X button -> No confirmation dialog is shown.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 13

10 years ago
Just to confirm Stefan's report, I never see the confirmation dialog for *existing* events after I edit them and change calendars -- not if I press the escape key and not if I click the X.

Lightning 2007081804 / TB 2.0.0.6 / WinXP
Flags: blocking-calendar0.7?
Keywords: relnote
Whiteboard: [qa discussion needed]
Assignee: michael.buettner → nobody
Status: REOPENED → NEW
Component: Calendar Views → General
Flags: blocking-calendar0.7? → wanted-calendar0.8?
OS: Windows XP → All
QA Contact: lightning → general
Hardware: PC → All
Setting wanted0.8- as the main Calendar developers will not devote any time to
this in the 0.8 timeframe. Patches are, of course, always welcome.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
(Reporter)

Comment 15

10 years ago
(In reply to comment #0)
I cannot reproduce it. But I can confirm what Stefan said in comment #12 (there's no confirmation dialog after pressing escape key
Component: General → Theme
Flags: wanted-calendar0.8-
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7

Updated

10 years ago
Flags: wanted-calendar0.8-
Version: Sunbird 0.7 → unspecified

Updated

9 years ago
Flags: wanted-calendar1.0?
Flags: wanted-calendar0.8-
Summary: [Proto] Event dialog: 'X' doesn't work for edited events → Event dialog: 'X' doesn't work for edited events
Component: General → Dialogs
QA Contact: general → dialogs
There has not been any activity on this one for a long time?

Does the issue still exist?

I get the confirmation dialog in any case (X or ESC) with switching calendars in any combination.

Or is this only for Lightning with wcap?

Comment 18

7 years ago
Seems it was fixed by later reported but identical Bug 464102.
Status: NEW → RESOLVED
Last Resolved: 10 years ago7 years ago
Flags: wanted-calendar1.0?
Keywords: relnote
Resolution: --- → DUPLICATE
Duplicate of bug: 464102
You need to log in before you can comment on or make changes to this bug.