Closed Bug 464994 Opened 13 years ago Closed 13 years ago

about:license and about:rights both contain similar text, potentially contradict each other

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 3.5

People

(Reporter: Gavin, Assigned: Dolske)

References

Details

(Keywords: verified1.9.0.11, verified1.9.1)

Attachments

(2 files, 2 obsolete files)

about:license contains some text that describes what license the software is available under, which seems to mostly match what we say in about:rights. Seems like we should avoid the redundancy (perhaps linking to about:license from about:rights and removing the text from about:license?).

One part I'm concerned about is about:license#exceptions (bottom of the page), which mentions the trademarks and logos. My understand of the new terms for the logos are that they now are MPL licensed, so listing them under exceptions seems contradictory.
Flags: blocking-firefox3.1?
Harvey, what do you think?
Not many people know about about:license, it's not prominently linked to in the code, and while IANAL, if there are two disagreeing bits of text in terms of rights and liabilities, the most permissive trumps.

It's not great, but ultimately I think we're fine and I'd rather this not put about:rights at risk on the branch.

Blocks Firefox 3.1, though.
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Keywords: late-l10n
(In reply to comment #0)
> One part I'm concerned about is about:license#exceptions (bottom of the page),
> which mentions the trademarks and logos. My understand of the new terms for the
> logos are that they now are MPL licensed, so listing them under exceptions
> seems contradictory.

That's incorrect, see: http://www.mozilla.org/foundation/trademarks/policy.html
Target Milestone: --- → Firefox 3.1
(In reply to comment #3)
> That's incorrect, see: http://www.mozilla.org/foundation/trademarks/policy.html

That's the trademark policy. It was pretty clearly stated in bug 404464 comment 26 that the logo files are now MPL licensed under copyright law.
That comment is about the logo files provided in unbranded builds. I interpreted it in that context, saying that since there was no TM restriction on the unbranded logos, they were indeed under MPL. However, since there *are* TM restrictions on the logos we ship with Firefox, we retain trademark restriction on those logos while still shipping the entire product under MPL.
Mike's summary in comment 5 is accurate. Although licensed under the MPL for copyright purposes, TM rights are reserved, which is consistent with the notice.
I think Gavin's valid in saying that we should try to clarify about:license for 3.1 (since we have the opportunity) but this doesn't need to block branch work.

Axel: please continue! :)
(In reply to comment #6)
> Mike's summary in comment 5 is accurate. Although licensed under the MPL for
> copyright purposes, TM rights are reserved, which is consistent with the
> notice.

You're referring to the official Firefox logo here (orange fox on blue globe), right? Mike's summary in comment 5 is refers to the "unbranded" logos, i.e. just the blue globe. I just want to make sure we're all on the same page here.
I personally am less worried about the logos, btw.

In about:rights, it says "Minefield is made available to you under the terms of the Mozilla Public License." AFAICT, we're having a flock of licenses though, which are compatible with the terms of the MPL, some of which require attribution to be so. Which is what about:license is about.

My understanding was that all that was fine for shipping code under a non-free license, aka, the EULA. Now about:rights reads as if we relicensed that third party code to MPL to me. Someone out there will find that difference worthwhile to bother us.
So, specifically about the EULA bits, might this be fixable by either simply removing the "Official binaries of this product released by the Mozilla Corporation are made available under the corresponding EULA." line, or repurposing it to refer to about:rights in some fashion? For example, something that echos the notification bar..."Firefox is free and open software from the non-profit Mozilla Foundation. <a href="about:rights">Know your rights.</a>"
The proposed change of language in comment 10 would work from a legal perspective.
Attached patch EULA patch v.1 (obsolete) — Splinter Review
This changes the text as described in comment 10 (except it just says "This product" instead of "Firefox", as we don't currently have the replaceable product name stuff here). I also removed the bolding of "source code" in the next paragraph, since it's no longer making a binary/source dichotomy.
Attachment #349528 - Flags: ui-review?(beltzner)
(Looking at the patch, I suppose we could update the source code availability link to https://developer.mozilla.org/en/Mercurial, while we're here.)
There is still a binary/source distinction - about:rights is about the binary you have in your hand (available under the MPL-based not-a-EULA), and about:license is about the source code that makes it up, different bits of which are available under a variety of licenses compatible with the MPL, including the MPL itself.

Harvey: are we now using the MPL-based about:rights stuff for all binaries we ship, including nightlies, unbranded builds etc?

If so, please use the following text at the top of about:license, replacing the EULA text:

<b>Binaries</b> of this product have been made available to you by the <a href="http://www.mozilla.org/">Mozilla Project</a> under the Mozilla Public License. <a href="about:rights">Know your rights</a>.</p>

Please remove the exceptions section and "Except as described here, " - we no longer (Yay!) ship anything which is not free software from a copyright stance. (The trademark restrictions, of course, stand, and are explained in the MPL, about:rights and in other places.)

And yes, please change the "available" link to the Mercurial page you reference :-)

We need better integration between these two pages. But this will do for now.

Gerv
Yes, all of the binaries are shipped under the MPL, concur with your proposed language change.
Attached patch Patch v.2Splinter Review
Attachment #349528 - Attachment is obsolete: true
Attachment #349847 - Flags: review?(gerv)
Attachment #349528 - Flags: ui-review?(beltzner)
Comment on attachment 349847 [details] [diff] [review]
Patch v.2

Great stuff. r=gerv.

Gerv
Attachment #349847 - Flags: review?(gerv) → review+
Priority: -- → P1
Removing late-l10n; it doesn't look like the text of about:license is being localized, so there shouldn't be any L10N impact with this patch.
Keywords: late-l10n
Assignee: nobody → dolske
Pushed http://hg.mozilla.org/mozilla-central/rev/32213f0701ef
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Interesting is that 'about:license' is linked from 'about:', 
but 'about:rights' is not linked from somewhere...
So, how can people find the about:rights page?
It's primary entry is the notification bar shown on first run. This bug also added a link to it in about:license.
Target Milestone: Firefox 3.1 → Firefox 3.5
Duplicate of this bug: 476920
Flags: wanted1.9.0.x?
Flags: blocking1.9.0.9?
Attachment #369624 - Flags: review?(gerv)
Oops. Looks like this got forgotten during the FF3.1B2 checkin rush. :(
Don't break Thunderbird...
Attachment #369624 - Attachment is obsolete: true
Attachment #369627 - Flags: review?(gerv)
Attachment #369624 - Flags: review?(gerv)
Comment on attachment 369627 [details] [diff] [review]
CVS trunk version (for 1.9.0) - v1.1

r=gerv.

Gerv
Attachment #369627 - Flags: review?(gerv) → review+
Flags: blocking1.9.0.10?
Attachment #369627 - Flags: approval1.9.0.10?
Flags: blocking1.9.0.9?
Flags: wanted1.9.0.x?
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.10?
Attachment #369627 - Flags: approval1.9.0.10? → approval1.9.0.10+
Comment on attachment 369627 [details] [diff] [review]
CVS trunk version (for 1.9.0) - v1.1

Approved for 1.9.0.10. a=ss
CVS trunk:

Checking in browser/base/Makefile.in;
/cvsroot/mozilla/browser/base/Makefile.in,v  <--  Makefile.in
new revision: 1.25; previous revision: 1.24
done
Checking in browser/base/content/overrides/app-license.html;
/cvsroot/mozilla/browser/base/content/overrides/app-license.html,v  <--  app-license.html
new revision: 1.3; previous revision: 1.2
done
Checking in mail/app/Makefile.in;
/cvsroot/mozilla/mail/app/Makefile.in,v  <--  Makefile.in
new revision: 1.93; previous revision: 1.92
done
Checking in toolkit/content/license.html;
/cvsroot/mozilla/toolkit/content/license.html,v  <--  license.html
new revision: 1.27; previous revision: 1.26
done
Keywords: fixed1.9.0.10
Verified fixed for 1.9.0.11 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.11pre) Gecko/2009051111 GranParadiso/3.0.11pre. Text is changed...
verified FIXED on builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090522 Minefield/3.6a1pre ID:20090522032716

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090522 Shiretoko/3.5pre ID:20090522030802
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.