When Thunderbird account is deleted, account display is not removed

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Michael Baffoni, Unassigned)

Tracking

({polish, regression})

Trunk
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081111 Shredder/3.0b1pre

Steps to repeat:

1) Create an account with bogus information.  Save and return to main Tbird window.
2) Reopen account settings, verify account is there.
3) Remove account.

Expected results:

4) Account disappears from list, next (or prior) account is selected and visible.

Actual Results:
4) Account settings disappear, but account name and placeholder remain, and stay selected.

Leaving account manager and re-entering account manager, information is no longer there, so I think this is just a polish issue.  I don't have enough technical know-how, but does this imply account information is not completely wiped?
I still believe you mean the entry within the folder pane. That's what I can see by testing account removal on OS X and Windows. Looks like the js driven folder pane is only half-wise updated. On OS X the account name isn't shown while it is visible on Windows.

I'll attach a screenshot.
Blocks: 414038
Component: Account Manager → Mail Window Front End
Keywords: regression
OS: Windows Vista → All
QA Contact: account-manager → front-end
Hardware: x86 → All
Created attachment 355371 [details]
Account display after removing it within the account manager
(Reporter)

Comment 3

9 years ago
Actually I do mean the account manager, not within the mail front-end window with the folder display.  I'm not seeing an error due to the account removal there (although I am seeing display issues when deleting folders, but that is a different bug,  Bug 470126).
(Reporter)

Comment 4

9 years ago
BTW, I'm not seeing this problem now on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1b3pre) Gecko/20090103 Shredder/3.0b2pre.  Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.