Useless empty tooltip shown when hovering the folder pane below the last folder / newsgroup

RESOLVED FIXED in Thunderbird 3.0b2

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: bugzilla.i.sekler, Assigned: philor)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b2
regression
Dependency tree / graph
Bug Flags:
in-testsuite ?
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [litmus or mozmill test required])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081116 Firefox/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081117 Thunderbird/3.0b1pre

If there is some space left below the last folder in the folder pane, hovering this free space results in a small (here on Linux: 8x8 px) empty tooltip being shown. First time seen in the 2008-11-13 Shredder nightly, possibly a regression from <http://hg.mozilla.org/comm-central/rev/1de58e1d7549> in the Bug 414038.

Reproducible: Always

Steps to Reproduce:
1. Make Thunderbird window high enough or collapse the folder tree to get free space below the last folder in the tree.
2. Hover this free space of the folder pane.

Actual Results:  
An empty tooltip appears.


Expected Results:  
No tooltip.
(Reporter)

Comment 1

10 years ago
Can't set the regression keyword because my Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081116 Firefox/3.1b2pre reproducibly crashes when entering more than two letters into the "keyword" form... :-O
Version: unspecified → Trunk
I can confirm this. Until build 20081112 all OK. Beginning with build 20081113 I see this empty tooltip.
(Reporter)

Comment 3

10 years ago
The reproducible crash while filling the "Keywords" form has gone with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081117 Firefox/3.1b2pre, thus allowing me to set the regression keyword.
Keywords: regression

Updated

10 years ago
Duplicate of this bug: 465595

Comment 5

10 years ago
Confirming, myself for Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b2pre) Gecko/20081117 Shredder/3.0b1pre nightly, also seen on
Mac per bug 465595, and further reports for Windows XP.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 6

10 years ago
It seems this bug is being caused by the bottom two folders, of the first mailbox entry, being (for whatever reason) set to the wrong encoding type.

I have four accounts, and the first one in the list showed "Arabic (IBM-864)" character encoding for the "Sent" and "Trash" folders.  You can access this setting by right-clicking either folder and selecting Properties...

When I tried to correct the problem by changing encoding for the "Sent" folder to "Western (ISO-8859-1)" (i.e. matching the other folders that are set correctly), clicking OK would not work.  I had to perform the modification on the "Trash" folder and, though clicking OK still seemed not to work, it corrected the setting for both "Sent" and "Trash" folders.

Now everything is fine and the blank tooltip is gone.
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> It seems this bug is being caused by the bottom two folders, of the first
> mailbox entry, being (for whatever reason) set to the wrong encoding type.
> 
> [...] When I tried to correct the problem by changing encoding for the
> "Sent" folder to "Western (ISO-8859-1)" [...], clicking OK would not work.
> I had to perform the modification on the "Trash" folder and, though clicking
> OK still seemed not to work, it corrected the setting for both "Sent" and
> "Trash" folders.
> 
> Now everything is fine and the blank tooltip is gone.

Can't confirm this workaround. The default character encoding for all folders of all my e-mail and newsgroup accounts was always set to ISO-8859-1; no effect on the empty tooltip in the folder pane changing it back and forth either.

Comment 8

10 years ago
My mistake.  My steps work only for the empty tooltip showing up for folders.  It does not eliminate the one associated with the blank space at the bottom.

However, since the empty tooltip shows up for folders when Thunderbird incorrectly selects the first (and in my case, wrong) character encoding type from the list, it would not surprise me if that is what is in fact happening -- even though there is no text there.  In that blank space, maybe there's a null string, that the incorrect character encoding is clobbering, and making it appear as though there is a tooltip?  Just a thought.

Comment 9

10 years ago
(In reply to comment #8)
> My mistake.  My steps work only for the empty tooltip showing up for folders. 
> It does not eliminate the one associated with the blank space at the bottom.

Yes, the empty tooltip for the folders themselves would be different from what is discussed here, and has been reported for builds before bug 414038 landed already. I've played with several character-set options without being able to get rid of it below the space occupied by the folders.

Comment 10

10 years ago
Somebody at mozillazine mentioned corrupted/unrebuilt .msf files as culprit for this bug:
http://forums.mozillazine.org/viewtopic.php?f=29&t=945395&st=0&sk=t&sd=a&start=15
Given the regression window, should be fallout from bug 414038.
<http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-11-12+03%3A00%3A00&
enddate=2008-11-13+03%3A00%3A00>
Blocks: 414038
(Assignee)

Comment 12

10 years ago
Created attachment 353150 [details] [diff] [review]
Fix v.1

Seems to do the trick.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #353150 - Flags: review?(jminta)

Comment 13

10 years ago
Comment on attachment 353150 [details] [diff] [review]
Fix v.1

+    if (gFolderTreeView._rowMap[row])
I'm inclined to say this should be row in gFolderTreeView._rowMap but I don't have strong preferences.

+      return gFolderTreeView._rowMap[row]._folder;
+    return false;
We should return null, not false.
Attachment #353150 - Flags: review?(jminta) → review+
(Assignee)

Comment 14

10 years ago
Good thing I was in the right place, with both of my two lines being wrong :)

Pushed the right thing in http://hg.mozilla.org/comm-central/rev/79fb05dfc64b
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b2

Updated

10 years ago
Flags: in-testsuite?
This FIXED bug is flagged with in‑testsuite?   It would be great if assignee or someone else can clear the flag if a test is not appropriate.  And if appropriate, create a test and plus the flag to finish off the bug.
Flags: in-litmus?
Whiteboard: [litmus or mozmill test required]
added under https://litmus.mozilla.org/show_test.cgi?id=7722
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.