Closed Bug 465522 Opened 14 years ago Closed 13 years ago

Bookmarks Toolbar Highlights Wrong Element, Shows Wrong Folder after Tooltip shown

Categories

(Core :: Widget: Cocoa, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: matthias.winkelmann+mozbugs, Assigned: mstange)

References

Details

(Whiteboard: [fixed by bug 443178])

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081117 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081117 Minefield/3.1b2pre

After lingering on an item in a bookmarks toolbar folder for a little longer than required for the tooltip to be shown, moving the mouse causes a brief highlight of a wrong element (usually the first or second in the folder. If the cursor has moved far enough horizontally to be under a different folder, that folder is shown instead of the one initially selected.

Reproducible: Always

Steps to Reproduce:
1. Have a few folders with bookmarks in the toolbar
2. Select a folder in the toolbar, move cursor to an element down the list, point cursor as far to the right as possible, but still over that item
3. wait for the tooltip to appear plus one or two seconds
4. move mouse
Actual Results:  
Highlights flicker all over the place, sometimes wrong folder is shown.
Version: unspecified → Trunk
Further observation: the problem doesn't appear when lingering on a subfolder, which do not show tooltips.
This is even weirder than you say.  And since it happens only on OS X
(not on Windows or Linux), it must be a Cocoa widgets bug.

1) Select a folder on the bookmarks toolbar with lots of items in it
   (I used "Latest Headlines").

2) Move the mouse down 10-15 items, then wait for the tooltip to appear.

3) Very slowly and carefully move the mouse to the right until it just
   moves off the right side of the menu (the menu item stops being
   highlighted and the tooltip disappears).

   Often (in my tests about 50% of the time) another menu item 7-8
   places above the current one will get highlighted.  And if you wait
   a few seconds its tooltip will appear.

   As you try this with menu items up and down in the list, you'll
   find that the menu item that gets highlighted in this step is
   always the same number of items above the one that was originally
   highlighted (that the mouse was over in step 2).
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Component: Places → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
QA Contact: places → cocoa
Assignee: joshmoz → smichaud
Priority: -- → P2
I've now observed the same behavior with website content. Try the table at http://thepiratebay.org/search/ubuntu/0/99/0
Same effect in the js-dropdown navigation at http://www.plos.org/about/faq.html
Depends on: 443178
Duplicate of this bug: 483550
Please see my above dup (bug 483550) for a description of how I have been able to reliably and easily duplicate this bug.
It could possibly help to zero in on a cause.
Is this still reproducible in the latest trunk nightly?
Seems fixed.
Assignee: smichaud → mstange
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 443178]
Target Milestone: --- → mozilla1.9.3a1
Presumably fixed by bug 443178.
You need to log in before you can comment on or make changes to this bug.