[Enhancement request] Add filter action for the execution of shell scripts/batch files/binaries

RESOLVED DUPLICATE of bug 80439

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 80439
10 years ago
10 years ago

People

(Reporter: algida79, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 

The addition of a new item in the "Perform these actions" list (Filter Rules dialog) enabling the launch of a user-specified shell script/batch file/binary would allow the automation of Thunderbird in many arbitrary ways, limited only by the specific needs of the user.


E.g. a user creates the following filter rule:

For incoming messages that Subject contains "APC" perform these actions: Execute "pysmssend -i /home/user/alerts/powerfailure.txt"

...in order to get notified by SMS in his cell phone when some UPS at his work kicks in and e-mails him about the power outtage.

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 80439
You need to log in before you can comment on or make changes to this bug.