update staging-master, production-master to build from the Firefox 3.1 maintenance branch

RESOLVED FIXED

Status

P2
critical
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

10 years ago
Severity: normal → critical
Priority: -- → P2
(Assignee)

Comment 1

10 years ago
Created attachment 349466 [details] [diff] [review]
enable production mozilla-1.9.1 builds, check-in staging 1.9.1 code

Alright, both of the mozilla2-staging/* diffs are exactly what is running on staging right now. We had some issues earlier related to disk space - but after cleaning up the slaves those resolved themselves. We're in a bit of a better place disk space wise on production, because we don't run unittests or l10n on the same slaves. Nonetheless, I went through and cleanup up all of the production slaves. I do not expect us to have those problems there.

Most of the config.py patch is a copy of the 'mozilla-central' branch with s/mozilla-central/mozilla-1.9.1/g performed. Things of note:
* repo_path has been added because 'mozilla-1.9.1' is in a subdirectory. We need that path for things like HgPoller, Mercurial Source step, and other things that touch the repository. We still need the short identifier for things like tinderboxBuildsDir, builder names, etc.
* major_version has been added because we are now in a place where this Buildbot builds for multiple code branches. It's usage is pretty obvious, I think.
* The slavelist for most things has become a bit outdated. *-slave03 moved to staging, for example. moz2-darwin9-slave05 and moz2-linux-slave13 are currently mozilla-1.9.1 unit test slaves. I've updated the slave lists to be current.
Attachment #349466 - Flags: review?(ccooper)
Attachment #349466 - Flags: review?(ccooper) → review+

Updated

10 years ago
Blocks: 464164
Attachment #349466 - Flags: checked‑in+
Comment on attachment 349466 [details] [diff] [review]
enable production mozilla-1.9.1 builds, check-in staging 1.9.1 code

Needed to check this in to not get out of sync with l10n. Seems to have run all weekend without issue.
(Assignee)

Comment 3

10 years ago
This should be totally fixed now.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 445794
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.