refactor mozilla2/master.cfg so the keys of the 'branches' dict aren't assumed to be repository names

RESOLVED DUPLICATE of bug 465735

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 465735
10 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
We've run into this when trying to set-up XULrunner builds off of m-c. We can't add branches['mozilla-central-xulrunner'] because 'mozilla-central-xulrunner' is not a repository. We can't add branches['mozilla-central']['win32-xulrunner'] without doing hacky things in the body of the loop. It's time to remove this assumption from the config. It's probably as simple as adding branches[name]['repository'] and changing the main loop to use that.
(Reporter)

Updated

10 years ago
Priority: -- → P3
(Reporter)

Updated

9 years ago
Blocks: 445191
(Reporter)

Comment 1

9 years ago
I'm an awful, awful person for letting this sit for so long. I'll get started on this now.
Priority: P3 → P2
(Reporter)

Comment 2

9 years ago
Created attachment 344314 [details] [diff] [review]
refactor master.cfg

Important parts of this patch include;
* Moving the HgPoller generation outside of the main loop. When we actually solve the bug this is blocking we'll end up with two "branches" which have 'mozilla-central' as their repository. This patch will make sure we only ever have 1 HgPoller per repository.
* Names of Schedulers, builders, build directories have not been touched. We can't switch them to be 'repository' instead of 'name' because they have uniqueness requirements.
* The 'branch' attribute of Schedulers and HgPollers has changed to 'repository'.

This patch should have no effect on current functionality - it simply enables us to solve the dep bug.
Attachment #344314 - Flags: review?(ccooper)

Updated

9 years ago
Attachment #344314 - Flags: review?(ccooper) → review+
(Reporter)

Comment 3

9 years ago
Created attachment 344525 [details] [diff] [review]
same thing for production

I've tested the previous patch well in staging, now here's the production version. (Same patch, just against different files).
Attachment #344525 - Flags: review?(ccooper)

Updated

9 years ago
Attachment #344525 - Flags: review?(ccooper) → review+
(Reporter)

Comment 4

9 years ago
I'm not planning to land this until xr builds get enabled...back in the pool for now.
Assignee: bhearsum → nobody
Status: ASSIGNED → NEW
Priority: P2 → P3
(Reporter)

Updated

9 years ago
Component: Release Engineering → Release Engineering: Future
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465735

Comment 6

8 years ago
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.