cannot import readonly google calendars

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
7 years ago

People

(Reporter: granoteta, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: 0.5.1

I have in my account several calendars shared from other people. If I can make changes in the shared calendar, I can import in Thunderbird. But if I can only see "See only free/busy (hide details)" I can't import it in Thunderbird. It seems as if I must use the id and password of the owner of the calendar.

Thanks.


Reproducible: Always

Steps to Reproduce:
1. Import a shared caledar where you onle can "See only free/busy (hide details)"

Actual Results:  
I have to introduce user and password of the calendar's owner. I can't use my own user and password. I have to cancel the import of the calendar.

Expected Results:  
Correct importation of the calendar
Purpose of the Provider for Google Calendar extension is getting write access to Google Calendar. You don't need it if you just want to read a Google Calendar. For that purpose create a normal iCalendar calendar using the ICAL feed provided by Google.
(Reporter)

Comment 2

10 years ago
I tried with ICAL feed and I cannot see any event from this calendar. I have marked it as read only, but I cannot see any event from it.
Duplicate of this bug: 468598
I think this might actually be a Google server bug, I remember reading something like that, but I cannot find the bug report right now. It would be great if someone could search the Google Calendar Data API group and the issue tracker at http://code.google.com/p/gdata-issues/issues/

Comment 5

10 years ago
a quick search didn't give actual results. Only this one 'might' be a corresponding isssue

http://code.google.com/p/gdata-issues/issues/detail?id=858

Inside the API I only found this example:

http://code.google.com/intl/und/apis/calendar/docs/1.0/developers_guide_js.html#Interactive_Samples

which gives me at least the name of my shared calendar. I didn't find any bug which you are referring to :/
Maybe I was mistaken then. Please enable debugging (see GData_Provider FAQ) and look at the debug information.

Comment 7

10 years ago
Created attachment 359494 [details]
screenshot of debuglog

Sorry, that I had to add a picture, but copy&paste didn't work. This is what I've got in the error log corresponding to that specific calendar (shared/readonly/ics-access)
Ah 0.9. I can't make any promises for 0.9 right now, google might have changed things. The next version of the provider is targeted for 1.0.

Please test with thunderbird3/lightning1.0pre or Sunbird1.0pre and a nightly version of the provider (0.6pre), at least to find out if the problem was fixed in the meanwhile.

Comment 9

10 years ago
I would, but somehow with the latest comm-central lightning/provider I'm not able to create a calendar ("new calendar" is grayed out)

Comment 10

10 years ago
Created attachment 359505 [details]
screenshot of debuglog #2

Here we go :)
Attachment #359494 - Attachment is obsolete: true
So it seems you don't have access to that calendar. Is this you trying to login as yourself (i.e your own credentials?). If not, please try this. Be sure to use the latest version (at least 1.0b1 and 0.6b1)

Comment 12

7 years ago
I think I'm seeing this behavior too, with TB6.0.2, Provider 0.8, and Lightning 1.0b5.  (I'm happy to upgrade if I'm not on the latest versions...)  I just tried subscribing to my advisor's calendar via ical -- http://www.google.com/calendar/ical/XXXXXXXX/public/basic.ics, where XXXXX is his email address, not mine, and I'm seeing some odd behavior.

1) Occasionally I'll get warnings in the console saying there's a minor problem, "description: NULL", and that lightning will continue...

2) I just tried reloading remote calendars, and while I didn't get any new warnings, the status-bar text reads "Checking Calendar 10 of 4294967295", which is worrisome but possibly unrelated...?

3) I tried enabling calendar.debug.log and calendar.debug.log.verbose, and I don't see the new calendar ever being queried.  (I don't see XXXXXXX in any of the messages.)

4) I noticed that on another calendar that I'd subscribed to, GData automatically converted the suffix /public/basic of the url (which is how it appears in right click -> Calendar properties) into /private/full (which is how it appears in the debug messages as the network requests).  If it's trying to do that to the other calendar also, which I don't own, and for which there's no way I would have access to /private/full, seems reasonable to me that might be a possible culprit...
Are you subscribed to your supervisors calendar in the Google Calendar Web Interface?

The message from (2) is unrelated, just ignore it :) The issue in (4) is ok also, I just use the URL you entered to retrieve the calendar name (i.e your email or the 123123@groups.google.com thing), the type of feed (private/public/basic/full) isn't kept.

Comment 14

7 years ago
Yes -- I subscribed by logging into the web interface, clicking in "Other calendars", typing "foo@gmail.com", and pressing enter, and sure enough I get his free/busy calendar.  I don't get any event details besides the free/busy information, as in comment #0.  And if I go to the Calendar Settings page, it shows up in the list of "Calendars I can only view".

Glad to hear problems 2 and 4 are unrelated :-p  Problem 2 may be its own bug, though, since it seemed to cause Lightning to get stuck and not refresh even the calendars it was successfully reading previously...

I should add -- I've tried subscribing to this calendar both through GData and through iCal, using the XML and iCal URLs from the web interface.  Neither of them seem to work.  Does GData recognize iCal URLs from Google and usurp them, or do they stay as regular iCal calendars?  Because the .ics file does exist and seems to be well-formed, at least to my un-expert eye...
Oh I remember an issue with calendars that only have free/busy access allowed, but I can't seem to find it. Sorry I overread this in your original post.

You could attempt to subscribe to the calendar via caldav, see:
www.google.com/support/calendar/bin/answer.py?hl=en&answer=99358#sunbird
Note a different url is used there.

(In reply to Ben Lerner from comment #14)
> I should add -- I've tried subscribing to this calendar both through GData
> and through iCal, using the XML and iCal URLs from the web interface. 
> Neither of them seem to work.  Does GData recognize iCal URLs from Google
> and usurp them, or do they stay as regular iCal calendars?  Because the .ics
> file does exist and seems to be well-formed, at least to my un-expert eye...
It should recognise from either xml or ical url, no difference there. The URl is only used to get the calendar name data.

You could check to see if the calendar is valid here: http://severinghaus.org/projects/icv/

Comment 16

7 years ago
According to severinghaus, the ics feed is indeed valid.  To clarify comment #14,  in the New Calendar wizard I tried subscribing to an iCalendar using both the XML link and using the ICAL link, and I tried subscribing to a Google Calendar using both the XML link and the ICAL link.  None of these worked, though they failed in different ways, I guess.

Subscribing via CalDAV worked -- manually rewriting the URL from its /ics/.../public/basic.ics version to the /dav/.../events version let Lightning succeed.  Not the most intuitive of subscription workflows, but that's a UI issue for another day :)  

(Random aside: It would be nice to have an auto-configured wizard, where you just shove in a URL, and Lightning figures out for itself which calendar type you want...and if it doesn't work, automatically ring the changes on that URL to see if a similar one does.  Especially when the buttons in Google Calendar read "XML", "ICAL" and "HTML", and not one of those is the same as "Google Calendar" -- the only button that matches is "ICAL", and that doesn't get you into a GData calendar!)

Thanks for the help with the workaround; if you find the issue you mentioned about free/busy access, link it here so I can follow that and not comment on the wrong bugs :)
Ok, closing this bug for now. I'll update it if that bug comes across my way. We are working on an auto-config dialog in bug 378873, but its not quite ready to handle Google Calendar links yet.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.