Message filters definition: allow folder selection from a non-flat list (but a tree with collapse/expand possibilities)

RESOLVED DUPLICATE of bug 315367

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 315367
9 years ago
6 years ago

People

(Reporter: tessarakt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [filter-mgmt])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.4) Gecko/2008111523 Gentoo Firefox/3.0.4
Build Identifier: version 2.0.0.18 (20081121)

Go to "Tools -> Message filters", "New ...":

Under "Perform these actions", the second field allows the selection of the folder.

This list is currently flat (ok, subfolders are indented ...), which might involve a lot of scrolling.

A better way would be the same way it is done when right-clicking on a message and selecting "Move to".

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Can someone please confirm this? Or is it a dupe?
Whiteboard: DUPME

Comment 2

9 years ago
It actually used to be like that (iirc before tb2?), but it was changed to the current format per design.
(Reporter)

Comment 3

8 years ago
Well, it's quite unusable for a large number of folders.

Can you give me a pointer to the discussion which lead to the change?
(Reporter)

Comment 4

8 years ago
P.S.: One could think of even more sophisticated folder pickers, maybe including a full text search, or including the ability to create a new folder.

Plus, I think there should  be a generic folder picker element/design (maybe customizable), to be used everywhere where the user has to choose a folder (I can only think of "Move to"/"Copy to" now - are there more uses?).
(Reporter)

Comment 5

8 years ago
(see bug 475160 for "M/C To" context menu)
(Reporter)

Comment 6

8 years ago
See also bug 536533 for a more generic solution idea.
(Reporter)

Comment 7

7 years ago
(In reply to comment #2)
> It actually used to be like that (iirc before tb2?), but it was changed to the
> current format per design.

Is there any info when and why this "design" was chosen?
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> (In reply to comment #2)
> > It actually used to be like that (iirc before tb2?), but it was changed to the
> > current format per design.
> 
> Is there any info when and why this "design" was chosen?

Ping. It is very annoying that so many bad UI was allegedly introduced "by design", and when one asks, one  does not get any info on the reasons of these design decisions.
Duplicate of this bug: 653138
Jens , maybe the people who did the design are long gone and hence the lack of answer.

Updated

6 years ago
Duplicate of this bug: 340708

Updated

6 years ago
Duplicate of this bug: 544349

Comment 13

6 years ago
Good proposal from bug 544349:
b) All Accounts were collapsed except the current Account when you first click the folder selection drop down (since there is a very good chance you will want to move it to a different folder on the same account)
Summary: Message filters definition: allow folder selection from a non-flat list → Message filters definition: allow folder selection from a non-flat list (but a tree with collapse/expand possibilities)
Whiteboard: DUPME

Comment 14

6 years ago
This seems to be a dupe of bug 315367. But other bugs are duped here (I can redupe those I did today). How to handle this? Which bug is better?
Blocks: 315367
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Whiteboard: [filter-mgmt]

Comment 15

6 years ago
The summary for bug 315367 is only talking specifically about the Move/Copy to function, but yeah, the comments support this being a dupe.

If you do dupe this to it, please change the summary of bug 315367 first to reflect the Filters folder picker, since this isn't an issue for the MOve/Copy functions any more...
Nobody is working on these olds bugs so it doesn't matter much how you dup. you choose and people who want to follow will.

Comment 17

6 years ago
(In reply to Charles from comment #15)
I think those are the "move to" and "copy to" filter actions, not right-click message operations. I think there is "filters folder picker" right in the beginning of the summary of bug 315367 and also in the description ("Create Filter from Message"...).

Or what did you mean?

(In reply to Ludovic Hirlimann [:Usul] from comment #16)
> Nobody is working on these olds bugs so it doesn't matter much how you dup.
> you choose and people who want to follow will.
We hope somebody will be able to work on them if we clean them up enough :)

Comment 18

6 years ago
(In reply to aceman from comment #17)
> (In reply to Charles from comment #15)
> I think those are the "move to" and "copy to" filter actions, not
> right-click message operations. I think there is "filters folder picker"
> right in the beginning of the summary of bug 315367 and also in the
> description ("Create Filter from Message"...).
> 
> Or what did you mean?

Never mind, I see that Ludovic already changed the Summary...

So, yes, this one should be duped to bug 315367
Thanks Charles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 315367

Updated

6 years ago
No longer blocks: 315367
You need to log in before you can comment on or make changes to this bug.