Enhance Account/Folder selection in Message Filters

RESOLVED DUPLICATE of bug 466247

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 466247
9 years ago
7 years ago

People

(Reporter: Charles, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 3.0.1 final

I'm surprised I couldn't find a request for this.

I have 16 IMAP accounts, some with a *lot* of folders.

When I want to create a filter for one of the accounts that happens to be lower in the hierarchy of Accounts, it is *really* cumbersome to select a folder (when the action I want to take is copy or move to another folder in that account).

What makes much more sense to me is if:

 a) The Accounts and Folders with subfolders were collapsible, and

 b) All Accounts were collapsed except the current Account when you first
    click the folder selection drop down (since there is a very good chance
    you will want to move it to a different folder on the same account)

Reproducible: Always
I think this is a combined duplicate of bug 392932 and bug 242693 (which just got fixed for 3.1 three days ago); resolving hesitantly as dupe of bug 392932, which is still open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392932
(Reporter)

Comment 2

9 years ago
Ummm... Nathan, I think you did this on the wrong bug. This is about account/folder selection in the message filters dialog. Nothing to do with autocomplete at all - although I did enter bug 544349, which *was* a dupe of bug 392932.

Setting back to unconfirmed...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Oops, you're quite right.

I'm guessing this really goes in MailNews Core, where Filters lives.

It would probably be simpler to switch the action control to act like the ones in Account Settings (under Copies and Folders), showing the currently selected folder name and having a drop-down button to change the folder, with hierarchical selections under that.

Better than that, but still pretty simple to do, would be reusing the current Folder Selection dialog from e.g. saved search properties, although you would have to adapt it to allow selection of only one folder rather than multiple.
Status: UNCONFIRMED → NEW
Component: General → Filters
Ever confirmed: true
Product: Thunderbird → MailNews Core
Hardware: x86 → All
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> It would probably be simpler to switch the action control to act like the ones
> in Account Settings (under Copies and Folders), showing the currently selected
> folder name and having a drop-down button to change the folder, with
> hierarchical selections under that.

Hmmm, ok, but when you're creating a new filter, there is no 'currently selected folder, so for new filters it should default to the current Account, with hierarchical selections from there...

> Better than that, but still pretty simple to do, would be reusing the current
> Folder Selection dialog from e.g. saved search properties, although you would
> have to adapt it to allow selection of only one folder rather than multiple.

Yeah, that would work too... 

So, I'd be fine with either way, as long as the starting point was logical (current account(+selected folder if this is an edit)...

Thanks for confirming...
QA Contact: general → filters

Updated

7 years ago
Duplicate of this bug: 664517

Updated

7 years ago
Duplicate of this bug: 677865

Updated

7 years ago
Duplicate of this bug: 660482

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466247
You need to log in before you can comment on or make changes to this bug.