Missing Outbox icon in Folder Pane

RESOLVED FIXED in Thunderbird 3.0b2

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: bugzillacat, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b2
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081121 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081121 Shredder/3.0b1pre

The "specialFolder" icon for Outbox is missing inside the Folder Pane's folderTree. This icon is displayed properly in a tabmail-tab, but a generic folder icon is being used inside the Folder Pane instead.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Seems really unlikely to be a coincidence that that's the only special folder whose specialFolder- property has a space in it.
Blocks: 414038
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

10 years ago
Just to narrow the regression window somewhat, it was still OK in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081013 Lightning/1.0pre Shredder/3.0b1pre ID:20081013031030
No longer blocks: 414038
OS: All → Windows XP
Hardware: All → PC
Version: Trunk → unspecified
Blocks: 414038
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 3

10 years ago
Per this thread -http://forums.mozillazine.org/viewtopic.php?f=29&t=956665 - another user reports that the image is OK with this build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080920112042 Lightning/1.0pre Shredder/3.0b1pre ID:20080920112042

Comment 4

10 years ago
OOPs
Actually meant to target this build for regression:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081113 Lightning/1.0pre Shredder/3.0b1pre ID:20081113031301

The icon is missing in that build.

Comment 5

10 years ago
And OK in build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Lightning/1.0pre Shredder/3.0b1pre ID:20081112031406
Marking as blocking, since this is a regression.
Flags: blocking-thunderbird3+
(Assignee)

Comment 7

10 years ago
setting TFV as b2
Target Milestone: --- → Thunderbird 3.0b2
(Assignee)

Comment 8

10 years ago
taking, though if someone knows how to fix this, please let me know :-)
Assignee: nobody → bienvenu
jminta, would you be up for taking a run at this bug, either for beta2 or beta3?
(Assignee)

Updated

10 years ago
Whiteboard: should be easy
(Assignee)

Comment 10

10 years ago
Created attachment 358760 [details] [diff] [review]
proposed fix

this fixes it, so I suspect Phil is right. All I did was replace "Unsent Messages" with "Outbox" in the css and xml/xul. I'm not sure if this affects SM so I've asked Neil for sr on the folderWidgets.xml and folderUtils.jsm part (though I'm not sure the latter is used in SM). Or perhaps Neil has thoughts on a simpler fix.
Attachment #358760 - Flags: superreview?(neil)
Attachment #358760 - Flags: review?(jminta)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Whiteboard: should be easy → has patch awaiting reviews
(Assignee)

Comment 12

10 years ago
Created attachment 358764 [details] [diff] [review]
address jminta's comment

mmm, I wonder why that method doesn't simply check the folder flags...
Attachment #358760 - Attachment is obsolete: true
Attachment #358764 - Flags: superreview?(neil)
Attachment #358764 - Flags: review?(jminta)
Attachment #358760 - Flags: superreview?(neil)
Attachment #358760 - Flags: review?(jminta)

Comment 13

10 years ago
So, what's going on here was that the old RDF code was returning "Unsent Messages" as the special folder, which was fine as a generic attribute, but when applied to tree properties got split up into two tokens. Fortunately nobody noticed because the same problem applied to the CSS.

Now, jminta's JS-based folder tree doesn't know about this and creates a single atom for "SpecialFolder-Unsent Messages" which unsurprisingly doesn't match any CSS rules.

So, while the fix is to change the special folder to one not using a space, since this has a knock-on effect on the folder menus (which use the same special folder names), which are shared with the suite, via such windows as the account manager, this means that the special folder name has to be updated throughout the comm-central tree, not just the Thunderbird parts.

As an interim fix you could instead tweak suite's copies of folderMenus.css so that they accept either special folder name, but you still wouldn't want to update suite's msgMail3PaneWindow.js, since that's still using the RDF value.
(Assignee)

Comment 14

10 years ago
thx for the info, Neil.

I looked at the suite's copies of folderMenus.css and neither of them seem to reference Unsent. Am I looking in the wrong place(s)?
(Assignee)

Comment 15

10 years ago
Created attachment 358988 [details] [diff] [review]
address Neil's comments

I found Unsent Messages references in suite's folderPane.css so I've added Outbox to them - is that what you intended, Neil? SM seemed to be working without that change, but I'm no expert :-)
Attachment #358764 - Attachment is obsolete: true
Attachment #358988 - Flags: superreview?(neil)
Attachment #358988 - Flags: review?(bugzilla)
Attachment #358764 - Flags: superreview?(neil)
Attachment #358764 - Flags: review?(jminta)

Comment 16

10 years ago
Comment on attachment 358988 [details] [diff] [review]
address Neil's comments

I suddenly realised that the only time the Unsent Messages folder appears in our UI is in the Go submenu, which is still RDF-based, and is therefore unaffected by the folderWidgets change.
Attachment #358988 - Flags: superreview?(neil) → superreview+

Comment 17

10 years ago
(In reply to comment #14)
> I looked at the suite's copies of folderMenus.css and neither of them seem to
> reference Unsent. Am I looking in the wrong place(s)?
No, you're quite right, and it's a bug, which I shall file in due course.
(Assignee)

Updated

10 years ago
Whiteboard: has patch awaiting reviews → [needs review Standard8]
Comment on attachment 358988 [details] [diff] [review]
address Neil's comments

This in general seems to be working, however you've missed both mailContentMenus.js instances:

http://mxr.mozilla.org/comm-central/source/mail/base/content/mailContextMenus.js#513

(Send unsent messages context menu item doesn't get displayed)

and you've also missed updating mail3PaneWindowCommands.js for SeaMonkey.
Attachment #358988 - Flags: review?(bugzilla) → review-
Whiteboard: [needs review Standard8] → [needs updated patch]
(Assignee)

Comment 19

10 years ago
(In reply to comment #18)

> 
> and you've also missed updating mail3PaneWindowCommands.js for SeaMonkey.
Ah, I didn't do that because in #13 Neil said not to do the suite's msgMail3PaneWindow.js, since that's still using the RDF value, and I thought he meant the suite's mail3PaneWindowCommands.js...
(In reply to comment #19)
> (In reply to comment #18)
> 
> > 
> > and you've also missed updating mail3PaneWindowCommands.js for SeaMonkey.
> Ah, I didn't do that because in #13 Neil said not to do the suite's
> msgMail3PaneWindow.js, since that's still using the RDF value, and I thought he
> meant the suite's mail3PaneWindowCommands.js...

Ah, ok, I must admit I didn't actually test that.
(Assignee)

Comment 21

10 years ago
Created attachment 359302 [details] [diff] [review]
address comments

I didn't change the SM context menu for the same reason...

I'm not seeing the outbox in my context menu, but that's also true in 2.0x, so there's something screwy with my profile...
Attachment #359302 - Flags: review?(bugzilla)
Attachment #359302 - Flags: review?(bugzilla) → review+
Comment on attachment 359302 [details] [diff] [review]
address comments

This works for both TB & SM. r=me.
(Assignee)

Comment 23

10 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [needs updated patch]
Attachment #358988 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.