Closed Bug 466311 Opened 13 years ago Closed 11 years ago

Accounts and folders missing after installs of Thunderbird 3

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: baffoni, Unassigned)

Details

(Keywords: regression)

Attachments

(2 files)

Latest version with issue so far: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081122 Shredder/3.0b1pre

I'm having a problem after installing new TB3 updates on my Vista machine.  After installing updates (from the TB3 autodownload feature), all my mail windows go blank (see attached jpeg); if I send an email, it will attempt to login and send message normally, but no folders appear.  However, opening the profile with Thunderbird2, it opens and operates normally.  This happened once before, and I was able to restore normal function by uninstalling the product, then reinstalling.  However, on this build, I tried it again, but it didn't fix the problem, so that may have been coincidental.

Renaming the Thunderbird app directory and allowing it to build a new profile, the folders appear normally with a clean profile.  So I assume there is something in the profile preventing the folders from showing that affects Thunderbird3 only.
More info is needed to analyze this report.

Try running in safe mode to eliminate extensions as the cause.
http://kb.mozillazine.org/Safe_mode
(If this works please mark this WORKSFORME)

What version of TB2 are you currently using.

Are there any errors in the error console.
Tools>>Error console.
Safemode did not work.

TB2: version 2.0.0.17 (20080914)

Errors in the console:
Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFolder.subFolders]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/folderPane.js :: ftv__mg_all :: line 707"  data: no]
(In reply to comment #2)
> Safemode did not work.
> 
> TB2: version 2.0.0.17 (20080914)
> 
> Errors in the console:
> Warning: Timed textboxes are deprecated. Consider using type="search" instead.
> Source File: chrome://messenger/content/messenger.xul
> Line: 0

This error is unrelated and is informational for developers only.  The issue is being tracked by Bug 451852
I attempted to reproduce this using a current trunk build with a branch profile from version 2.0.0.17pre (20080821) which worked fine.


The reporters second error:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFolder.subFolders]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://messenger/content/folderPane.js :: ftv__mg_all :: line 707"  data: no]
Points to Bug 414038 code

This could be important for future upgraders from tb2 to tb3
CC: wsm and david for input.
http://mxr.mozilla.org/comm-central/source/mail/base/content/folderPane.js#705

705       // force each root folder to do its local subfolder discovery.
706       for each (acct in accounts)
707         acct.incomingServer.rootFolder.subFolders;
Keywords: regression
This happened to me too - when I autoupdated last night, except I get a slightly different error message in the console. Not filing a new bug for now...

Error: this._treeElement is undefined
Source File: chrome://messenger/content/folderPane.js
Line: 231
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #6)
> This happened to me too - when I autoupdated last night, except I get a
> slightly different error message in the console. Not filing a new bug for
> now...
> 
> Error: this._treeElement is undefined
> Source File: chrome://messenger/content/folderPane.js
> Line: 231

I also saw this error *Once* only and it will not reproduce. If this happens again, a new bug needs to be filed as it is different than this bus issue.
This will catch the exception and hopefully allow start up to continue normally so that at least some accounts are displayed.

Without further information as to the cause of the failure, it is difficult to say if there will still be problems with some (or all) accounts in the profile. Hence we are trying this to see if it will improve matters.
Attachment #350677 - Flags: review?(bienvenu)
Comment on attachment 350677 [details] [diff] [review]
[checked in] Catch the exception

yes, let's give this a try, thx.
Attachment #350677 - Flags: review?(bienvenu) → review+
Comment on attachment 350677 [details] [diff] [review]
[checked in] Catch the exception

Checked in: http://hg.mozilla.org/comm-central/rev/d209b761def1

This will be available in tomorrows (20081201) nightly builds. Please can folks who are seeing this problem test again and report back.
Attachment #350677 - Attachment description: Catch the exception → [checked in] Catch the exception
That allowed me to see the account folders again.  I see this in the error console:

Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Discovering folders for account failed with exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFolder.subFolders]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/folderPane.js :: ftv__mg_all :: line 710"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFolder.abbreviatedName]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://messenger/content/folderPane.js :: anonymous :: line 1002"  data: no]
 
[The last error is repeated 14 times]
(In reply to comment #11)
> That allowed me to see the account folders again.  I see this in the error
> console:
> 
> Warning: Timed textboxes are deprecated. Consider using type="search" instead.
> Source File: chrome://messenger/content/messenger.xul
> Line: 0

You can disregard this error as it is informational.  The switch to another type of textbox is being tracked on another bug for the 14+ instances of 
 
> Discovering folders for account failed with exception: [Exception... "Component
> returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND)
> [nsIMsgFolder.subFolders]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" 
> location: "JS frame :: chrome://messenger/content/folderPane.js :: ftv__mg_all
> :: line 710"  data: no]
> 
> Error: uncaught exception: [Exception... "Component returned failure code:
> 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIMsgFolder.abbreviatedName]"  nsresult:
> "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
> chrome://messenger/content/folderPane.js :: anonymous :: line 1002"  data: no]
> 
> [The last error is repeated 14 times]
Does this information from the error log help determine why I can now see the accounts/folders, or do I  need to collect more information to help this bug?
Does there appear to be any data missing? or do you think it has all come across?

Also, do the errors appear every time you start up?
Everything appears to be there. 

Yes, the errors appear on each restart.
Duplicate of this bug: 468656
If there is no new work on this bug, should I mark this WFM, or was the fix simply to stop doing error checking, and we should leave this new?
I think we should leave this open to figure out why you're getting those errors. I believe it has something to do with your profile directory, so seeing a listing of the files in your profile directory (including sub-directories) would be helpful.
Severity: critical → normal
(In reply to comment #18)
> I think we should leave this open to figure out why you're getting those
> errors. I believe it has something to do with your profile directory, so seeing
> a listing of the files in your profile directory (including sub-directories)
> would be helpful.

Is this possibly related to nsIMsgFolder migrating to a module? Saw a post by an extension developer in m.d.a.t that He is having a problem with .subFolders.
nsIMsgFolder is an interface - an interface can't be a module. That post was about the nsIMsgFolder interface changing, and is unrelated to this problem. The direct cause of this problem is the folder pane being changed to a js-driven tree, and getting an unexpected error calling GetSubfolders. But I don't know what's causing that error in the c++ implementation.
Sorry for tossing in a "Red Herring".
Duplicated account:

This is the first time I've commented on a bug, so if I'm doing this incorrectly, my apologies and please redirect me.

I have just installed Shredder 3.0b2pre on Windows XP. I downloaded it from nightly/latest-trunk marked Dec 29, 2008 04.29

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Thunderbird/2.0.0.9 Mnenhy/0.7.5.666

Previously I used 2.0.0.19.

When I use 2.0.0.19 I have two accounts. One connects to one ISP, the other connects to a different ISP, and they have unrelated email addresses.

When I use 3.0b2pre one of those accounts appears twice in the folderpane. Everything is duplicated in the second duplicate. If I click once on a message in the first duplicate, then go to the second duplicate, the message is marked there as well. I can use either duplicate account satisfactorily.  I have compared each subsection under "Account settings" for the two duplicates, and I can find no differences. There are no duplicated accounts in my mail subdirectory in my profile.

I see from earlier in this thread that you may be wanting input from other users who have experienced this problem. Is there any information you wish from me?

thanks.
(In reply to comment #22)
> Duplicated account:
Harold Munn, you are probably looking phenomenon of Bug 303542.
See Bug 303542 Comment #6, and check entries in prefs.js.
My experience is different, I think.
Bug 303542 seems to happen when a new account is created.
I did not create or delete any accounts before or after installing the new nightly. 
2.0.0.19 still shows my original two accounts correctly. 
3.0b2pre shows the same accounts but with one of them duplicated. 
If I close 3.0b2pre and re-open 2.0.0.19, the original two accounts are present without the duplicate. 
Is this what is happening in bug 303542?
(In reply to comment #24)
> Is this what is happening in bug 303542?
No. When Bug 303542, Tb 2 displays two accounts, and doesn't display account of garbage(hidden account, hidden even by account manager). Tb 3 displays two account + third account of garbage(hidden when Tb 2), and the third account becomes DUP of another account.

Garbage in following entries may be relevant to your problem.
Is there "wrong pointer(points to non-existent entry)", "excess entry(pointed by no one)"? Is there multiple entries who have same serverQ.hostname/serverQ.userName value?

> user_pref("mail.accountmanager.accounts","...,accountN,...");
> user_pref("mail.account.accountN.identities", "idP"); ("Local Folders" doesn't have this entry)
> user_pref("mail.account.accountN.server", "serverQ");
> user_pref("mail.identity.idP.useremail", "xP@xP.xP.xP");
> user_pref("mail.server.serverQ.hostname", "xP.xP.xP");
> user_pref("mail.server.serverQ.userName", "xP");
> user_pref("mail.server.serverQ.realhostname", "yyQ.yyQ.yyQ");
> user_pref("mail.server.serverQ.realuserName", "yyQ");
I found entries such as 
user_pref("mail.account.account4.server", "server4");
but I have only three accounts.

I deleted all references to account4 and server4 and now it works fine - the duplicate account has disappeared.

I hope this is of some use to you. Any other information that will help?

Thanks.
Michael, can you test earlier builds to get a regression range?  (unless the patch is needed).  Sounds a regression window is needed to get to the heart of comment 18.
Component: General → Mail Window Front End
QA Contact: general → front-end
Unfortunately I can no longer replicate the issue.  I had been frustrated in trying to find the SMTP server settings on one of the earlier Tbird3 builds, and couldn't for the life of me figure out why I could see the SMTP tab in Account Manager fine in TB2, but it was completely missing in TB3.  While I was poking around in TB2, I found a newsgroup that had been configured to point to a MS newsgroup server, but it didn't have any name, or other identifying information.  So I deleted it in TB2, and suddenly in TB3 I could see the outgoing server (SMTP) option, and (not coincidentally) I no longer got the odd error in the error console.  So it looks like I had a non-conforming config in the account manager that TB2 thought was legit, but TB3 couldn't handle, let alone identify why it didn't like it.

At this point this bug is WFM, but maybe it should be renamed to address improved error handling on the account manager data.
could be you were seeing bug 476135
Could be related, although I never got an account wizard dialog box.
Michael in comment #28
> Unfortunately I can no longer replicate the issue.  

Michael, to determine whether the problem is gone, can you test if it fails running the version from your previous report on 2008-12-02?  If you can't reproduce then your profile has changed and the problem may not be gone.
I restored my profile as of 1/5 in the user/<user>/appdata/roaming/thunderbird.... etc., and I'm not seeing the old newsgroup that I deleted/removed in either TB2 and TB3, let alone the error.  In XP, restoring the prefs.js or the entire profile should have been sufficient, but in Vista, this doesn't seem to be working.  Is there another directory I need to restore in Vista to recover my profile back the way it was on 1/5?
Yes. 
user/<user>/appdata/local/thunderbird...
This is where Update and quick start info is stored, and for Shredder the Caches.
sound like the remaining issue is WFM for Michael, so closing fixed. feel free to correct TM.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0a3
I came here via the comment in MailUtils.js.
Although this has been marked as fixed I found a way to reproduce the exception. Maybe this indicates the real cause of the problem or a link to some other bug:

Start Thunderbird (Safe Mode)
Create new Email-Account
  Name: Test
  Email: test@xn--csszr-yqac.de
Change detected settings to POP, re-detect
Choose Custom Settings (or OK; both will not work properly) to create the account
Close Thunderbird
Start Thunderbird (Safe Mode)
-> Find the exception in the error console

Discovering folders for account failed with exception: [Exception... "Component returned failure code: 0x80550016 [nsIMsgFolder.subFolders]"  nsresult: "0x80550016 (<unknown>)"  location: "JS frame :: file:///E:/Mozilla%20Thunderbird/modules/MailUtils.js :: MailUtils_discoverFolders :: line 77"  data: no]
(In reply to David Császár from comment #35)
> Create new Email-Account
>   Name: Test
>   Email: test@xn--csszr-yqac.de
> Change detected settings to POP, re-detect
> Discovering folders for account failed with exception: [Exception...
> "Component returned failure code: 0x80550016 [nsIMsgFolder.subFolders]" 
> nsresult: "0x80550016 (<unknown>)"  location: "JS frame ::
> file:///E:/Mozilla%20Thunderbird/modules/MailUtils.js ::
> MailUtils_discoverFolders :: line 77"  data: no]

Yes, I can reproduce this, but please not follow this in this closed bug. Bug 1360836 seems to have the same symptoms so let's continue there.
You need to log in before you can comment on or make changes to this bug.