Last Comment Bug 46647 - (coffeehandler) Joke: HTCPCP not supported (RFC2324)
(coffeehandler)
: Joke: HTCPCP not supported (RFC2324)
Status: RESOLVED INVALID
[Do not reopen this joke or comment o...
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All All
: P3 enhancement with 14 votes (vote)
: Future
Assigned To: Darin Fisher
: Nobody; OK to take it and work on it
: Patrick McManus [:mcmanus]
Mentors:
coffee://anything
: 535653 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-27 07:48 PDT by Eric Hodel
Modified: 2016-08-03 19:48 PDT (History)
46 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Eric Hodel 2000-07-27 07:48:49 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m17) Gecko/20000726
BuildID:    2000072608

The Hyper Text Coffee Pot Control Protocol is not supported.  Support of this
protocol will allow developers to be more efficient in their daily tasks because
they will no longer have to spend time waiting for coffee to brew because they
will know when the coffee maker is out of coffee.

Reproducible: Always
Steps to Reproduce:
1. Get an HTCPCP-compliant coffee pot and attach it to the network
2. Open Mozilla
3. Browse to the coffee pot via coffee://coffee.pot.name

Actual Results:  coffee is not a registered protocol

Expected Results:  Mozilla interfaces to the coffee pot specified and allows
brewing, etc.

HTCPCP RFC:  http://www.rfc-editor.org/rfc/rfc2324.txt

Many people on irc.mozilla.org channel #mozillazine frequently leave for an
extended amount of time to get coffee.  If they had a HTCPCP enabled browser
their coffee trips would be shorter allowing them to spend more time resolving bugs.

With mozilla supporting the coffee: URI scheme people everywhere will rejoice
because they no longer will need to spend as much time away from their
computers.  Resolving this bug not only benefits the developers of Mozilla, but
also mozilla users everywhere.
Comment 1 Rann Bar-On 2000-07-27 07:55:21 PDT
Yes, I agree.  The importance of coffee to both developers and end-users cannot
be underestimated.  It is undoubtably one of the most undisputable facts on the
web today: coffee is an essential ingridient of modern living.  If Mozilla is to
become an accepted browser, it must support coffee, in all its forms and
variations.  HTCPCP is an essential feature and must be implemented asap.  
Comment 2 Rann Bar-On 2000-07-27 08:00:49 PDT
adding self to cc list
Comment 3 Peter 'Rufus' Nelson 2000-07-27 11:55:50 PDT
setting plat/os to all
Comment 4 Aaron Lehmann 2000-07-27 13:07:33 PDT
*** This bug has been confirmed by popular vote. ***
Comment 5 Hixie (not reading bugmail) 2000-10-20 22:35:19 PDT
We're going to need a testcase before we can easily implement this -- reporter,
are you aware of any servers that are running an HTCPCP service, and that we
could have access to when implementing this? Thanks.
Comment 6 benc 2001-05-23 12:44:42 PDT
mass move, v2.
qa to me.
Comment 7 David Gerard 2002-01-08 03:51:21 PST
The implementation of this should be via a plugin API for beverages in general,
so that the Download Manager can brew a nice cup of tea while you're fetching
pr0n^Wmp3s^Wlarge and important files for business purposes, as per
news://slrna3loe4.dp.fun@aspc083.longword.dyndns.org .

RFC2324 does not specify how to brew tea. In fact, I cannot find a standard
that mentions 'tea' in the title or summary. Perhaps Mozilla will need to strike
forward, creating an interface based on eXtensible Tea Language.
Comment 8 Jonas Jørgensen 2002-01-08 05:49:20 PST
Wouldn't this be nsdogfood? ;~D
Comment 9 Sören 'Chucker' Kuklau (gone) 2002-02-16 13:59:03 PST
Once the eXtensible Beverage Protocol (XBvL, because XBL is already used) is
finished, we need to add initial support for

- coffee
- beer for the Germans out there (like me)
- tea
- milk
- Polnish Vodka

. Of course, we need to make XBvL able to combine beverages, such as coffee with
milk. And what about sugar?
Comment 10 David Gerard 2002-02-16 20:19:04 PST
I think the first order of business with this bug is to come up with a working
reference implementation. This way, we can have a working example with an
insufficient, defective and mathematically incomplete API which needs extra
stuff bolted on the side to make it usable elsewhere, but will never ever be
able to be fixed up properly and made clean for fear of breaking backward
compatibility, as every implementor just copies the original interface without
regard for its long-term usability. If we can make sure it has such an API, it
will increase the chances of Microsoft implementing it in IE, making HTCPCP
more available to the uncaffeinated masses.

(Sort of like the exact opposite of the problem with implementing CSS2. MIT
approach or New Jersey approach? That's always the question.)
Comment 11 Sören 'Chucker' Kuklau (gone) 2002-02-17 02:56:13 PST
You know very well that _if_ Microsoft will ever support it, they will use
proprietary extensions.

They won't support Beck's Beer, but only MS Beer 2003, for instance.

Thus, we should never do any compromises for Microsoft concerning this bug.

Still, a cross-platform API might become useful for other competition such as
Opera and iCab.
Comment 12 Zibi Braniecki [:gandalf][:zibi] 2002-09-03 05:27:26 PDT
Can we add dependency to bug 163993? 

And i would change summary to "Lets make Mozilla coffeehandler"
Comment 13 fileman 2003-09-17 06:07:43 PDT
Not supporting Beck's beer is not a big deal (it contains preservatives that
make people have diarrhoea ;) ) But I agree, it wouldn't be a good thing to let
Microsoft mess around with HTCPCP... perhaps they would set up a licensing model
for breweries or some other EVIL thing.

I volunteer writing the ROTHAUS ZÄPFLE extension as soon as there is an SDK.

Regards, fileman ;)
Comment 14 Neil Parks 2003-09-17 11:40:26 PDT
Please note the month and day of month that the alleged RFC was written.

(quote)
Network Working Group                                       L. Masinter
Request for Comments: 2324                                 1 April 1998
Category: Informational

2.3.2 418 I'm a teapot

   Any attempt to brew coffee with a teapot should result in the error
   code "418 I'm a teapot". The resulting entity body MAY be short and
   stout.

(end quote)

With all the real bugs that still need to be fixed, does stuff like this really
need to remain open?
Comment 15 Eric Hodel 2003-09-19 10:07:12 PDT
Just because its an April Fools RFC, doesn't mean it won't ever be implemented.
 Look at IP over Avian Carriers...

Have a sense of humor.
Comment 16 Stefan Moebius 2003-09-24 03:32:50 PDT
RJ Tarpley's offer (see http://www.mozillazine.org/articles/article3732.html)
turns up a severe deficiency of RFC2324. The protocol does not provide a return
code for "Out of coffee", nor does it provide a way to re-order coffee via,
e.g., a redirect to some webshop or via a Hyper Text Coffee Order Protocol
extension to HTCPCP. 

I suggest improving the protocol before trying to implement this in mozilla. It
may seriously hurt mozilla's reputation if developers across the world rely on
an insufficient protocol and are cut-off from their coffee supply.
Comment 17 benc 2003-10-21 17:43:01 PDT
->defaults. Module owner can decide.
Comment 18 John Lee 2003-12-12 00:56:34 PST
I'd appreciate it if support could eventually be added for non-coffee/tea
drinkers in the proposed XBvL standard. I, for one, enjoy coconut water. ;-)
Comment 19 Grant Galitz 2011-05-24 20:41:04 PDT
Can I get Firefox 4 to brew me coffee yet?
Comment 20 Tony Mechelynck [:tonymec] 2011-07-08 03:18:11 PDT
This bug was RESOLVED INVALID for no reason (literally: there is no comment dated 2005-04-24). If the RFC is incomplete, then the obvious solution is to publish an amended RFC, which should be the subject of a different bug (possibly a Tech Evangelism bug if Mozilla engineers don't have any power to make a Request For Comments themselves) blocking this one. My understanding is that the amended RFC should be published on the anniversary of the original RFC.

=> REOPENED.
Comment 21 Jacob Courtneay 2011-10-18 02:04:05 PDT
It's beyond me how the Mozilla team is off building flashy new features while there are showstopping bugs like this that have just been rotting away for over a decade. Why don't the devs listen to their users?
Comment 22 Nuno Silva 2011-11-07 15:12:46 PST
The devs aren't listening to their users because they're short on coffee.

This bugs needs to be fixed in order to get the devs to fix it.
Comment 23 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2011-11-07 18:55:29 PST
The fun is over. Everybody on the networking team gets email whenever this bug changes and this needs to be the last email we get on this subject. Sorry to be a buzzkill.

Please do not reopen this joke or comment on it any farther. Thanks for your cooperation.
Comment 24 Stewart Gordon 2012-11-17 05:33:33 PST
*** Bug 535653 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.