Closed Bug 466510 Opened 13 years ago Closed 13 years ago

Can't create saved search or view folder; openNewVirtualFolderDialogWithArgs is not defined

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: philor, Assigned: Bienvenu)

References

Details

(Keywords: regression)

Attachments

(1 file)

Fallout from bug 414038, which removed openNewVirtualFolderDialogWithArgs from widgetglue.js.

1. Search in quicksearch
2. From the menu select Save Search as a Folder

or

1. Add the View widget to the toolbar
2. Select something like Last 5 Days
3. Select Save View as a Folder

Actual:
Nothing happens other than:

Error: openNewVirtualFolderDialogWithArgs is not defined
Source File: chrome://messenger/content/msgViewPickerOverlay.js
Line: 76
Flags: blocking-thunderbird3.0b1?
blocking b1
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b1
You probably want gFolderTreeController.newVirtualFolder() instead.
thx, Joey, I'll take a quick whack at this.
Assignee: nobody → bienvenu
Though since one of the callers is in mailnews/extensions/, you probably "want"
a openNewVirtualFolderDialogWithArgs() which passes the Args to
.newVirtualFolder() :/
Attached patch proposed fixSplinter Review
standard, just need sr for the mailnews/extensions/mailview part since its shared code, thx!
Attachment #349797 - Flags: superreview?(bugzilla)
Attachment #349797 - Flags: review?(jminta)
Whiteboard: [has patch for review]
Attachment #349797 - Flags: review?(jminta) → review+
Comment on attachment 349797 [details] [diff] [review]
proposed fix

Wrapping the args so they're < 80chars would be nice.
I've wrapped them locally...
Whiteboard: [has patch for review] → [needs sr Standard8]
Flags: blocking-thunderbird3.0b1?
Attachment #349797 - Flags: superreview?(bugzilla) → superreview+
Whiteboard: [needs sr Standard8] → [bienvenu to land patch]
fix checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [bienvenu to land patch]
You need to log in before you can comment on or make changes to this bug.