Error: uncaught exception: 2147500034

RESOLVED DUPLICATE of bug 459790

Status

()

RESOLVED DUPLICATE of bug 459790
10 years ago
10 years ago

People

(Reporter: wsmwk, Assigned: bent.mozilla)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: )

(Reporter)

Description

10 years ago
seen with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081124 Shredder/3.0b1pre

message search kicks Error: uncaught exception: 2147500034 for every folder it traverses

regression range is 2008-10-12 -- 2008-10-13, so assuming this is regression of bug 455436, like bug 459790 (core+xpconnect)
(Reporter)

Comment 1

10 years ago
exception not kicked for folder currently selected/focused in folder pane.
also, don't see this with saved folders. only seen with "search messages"
(Reporter)

Comment 2

10 years ago
Do you see this with seamonkey?

Comment 3

10 years ago
Yes, confirming this for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081125 SeaMonkey/2.0a2pre Build ID: 20081125001350 searching on IMAP account with all subfolders.
Anyone feel like trying attachment 350197 [details] [diff] [review] to see if it fixes this bug?

Comment 5

10 years ago
I get these when I start Chromebug on FF3.1b2:
errorHook: uncaught exception: 2147500034@chrome://chromebug/content/chromebug.xul.30
errorHook: uncaught exception: 2147500034@file:///C:/bartonjj/projects/fireclipse/fbug/branches/firebug1.4/components/firebug-service.js.157
errorHook: uncaught exception: 2147500034@chrome://fb4cb/content/lib.js.14
errorHook: uncaught exception: 2147500034@chrome://global/content/globalOverlay.js.67
errorHook: uncaught exception: 2147500034@chrome://global/content/globalOverlay.js.67
errorHook: uncaught exception: 2147500034@chrome://fb4cb/content/tabCache.js.11
errorHook: uncaught exception: 2147500034@chrome://chromebug/content/ChromeBugPanel.js.51
errorHook: uncaught exception: 2147500034@chrome://chromebug/content/tracePanel.js.14

Those are all from my pre-startup error tracker.
Then I get another ten or twenty:
exception: 2147500034@file:///C:/Program%20Files/Mozilla%20Firefox%203.1%20Beta%201/components/nsSessionStore.js:215.0

These are not helpful.

Updated

10 years ago
Whiteboard: [firebug p1]
Should be fixed in b3 and on trunk after bug 459790 landed. Please verify.

Updated

10 years ago
Whiteboard: [firebug p1] → [firebug-p1]

Comment 7

10 years ago
I built:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090105 Shiretoko/3.1b3pre

I get
"uncaught exception: 2147500033"
Flags: blocking1.9.1?
(Reporter)

Comment 8

10 years ago
I see no errors when using 
11-28 build and most recent
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081128 Shredder/3.0b1pre
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090105 Shredder/3.0b2pre

John, under what circumstances do you see 2147500033?
(don't see any other bug that covers 2147500033)

Comment 9

10 years ago
fbs.onError with this.showStackTrace=true and this.breakOnErrors=false kind=Uncaught-Exception msg=uncaught exception: 2147500033@file:///G:/mozilla/mozilla-central/src/obj-i686-pc-mingw32/dist/bin/modules/utils.js:114.0

The caller is browser.js
1168 // Delayed initialization of the livemarks update timer.
1169 // Livemark updates don't need to start until after bookmark UI
1170 // such as the toolbar has initialized. Starting 5 seconds after
1171 // delayedStartup in order to stagger this after the microsummary
1172 // service (see above) and before the download manager starts (see below).
1173 setTimeout(function() PlacesUtils.livemarks.start(), 5000);

Where are these numbers coming from anyway?

Comment 10

10 years ago
This is nominated for blocking 1.9.1, but is in a mailnews component and is a firebug bug? Should this be in XPConnect? Is it possible to construct a smaller testcase, or be more specific?

Comment 11

10 years ago
Ok I take it back. It's the message that annoys me.  It doesn't really stop anything about Firebug and I guess that something is blocking the propagation of the message up to the ErrorConsole. It looks like the livemarks service is failing, so what.
Flags: blocking1.9.1?
I can see this error on the Firefox beta (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2), every time I use the FUEL library to access preferences.
Given that some extensions may rely heavily on this library, I think the Error Console is going to be swamped with messages like this.
Flags: wanted1.9.1?
Apparently nobody's troubled by the fact that this bug is about a mailnews error that no longer exists, and everyone's going to treat it as the one true 2147500034 bug, so moving elsewhere.
Component: Search → XPConnect
Product: MailNews Core → Core
QA Contact: search → xpconnect
Summary: message search kicks Error: uncaught exception: 2147500034 for every folder it traverses → Error: uncaught exception: 2147500034
(In reply to comment #12)

Please see comment 6. If you can provide a testcase that shows the bug *after* that fix landed (your b2 is too early) then that would be great!
(In reply to comment #7)
> I get "uncaught exception: 2147500033"

I don't see how that is related to this bug... That is NS_ERROR_NOT_IMPLEMENTED (not NS_ERROR_NOINTERFACE, which is what this bug is about).
Ah, sorry, I guess I didn't see comment 6. I can confirm that the error has disappeared for Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090202 Shiretoko/3.1b3pre.
I do see 2147500033 now, which wasn't happening in b2, but that's a different bug.
Then I think we should resolve this as a dupe of bug 459790.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: wanted1.9.1?
Resolution: --- → DUPLICATE
Duplicate of bug: 459790

Updated

10 years ago
Whiteboard: [firebug-p1] →
You need to log in before you can comment on or make changes to this bug.