Stop automatically processing reports for old versions after a few days

RESOLVED WONTFIX

Status

Socorro
General
RESOLVED WONTFIX
9 years ago
6 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

As I mentioned in bug 466528 comment 0, we should stop processing reports for old versions after we freeze topcrash reports (bug 466528). The exception is crash reports that enter the priority processing queue, which should get processed regardless of version.

This depends on having the ability to freeze topcrash reports.

Comment 1

9 years ago
this would also reduce load on server
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466528
Reopening - this is still a separate issue from bug 466528.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 521362
Duplicate of this bug: 466528
We should be able to do this with the admin panel and the CRUD page for branches/versions.
Target Milestone: --- → 1.2
Note: Not sure if this is actually dependent on the collector.
yes, this is very dependent on the collector.  Providing a way to quickly disregard a prod/version is one of my improvements to the collector in Bug 521362 that needs to be addressed before FF3.6 ships and the collector volume goes up.  Another complication is making the collector configuration easy to administer.  While it would be nice to have the admin/CRUD page for this configuration, the collectors don't have database access.
We're not concerned about load on the server, and we don't want to stop processing reports in case that data is needed to spot trends in versions that people are still using.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

6 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.