Misbehavior of autocomplete widget onStartLookup()

VERIFIED FIXED in M18

Status

()

Core
XBL
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Radha on family leave (not reading bugmail), Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

Attachments

(1 attachment)

The autocomplete widget fires a onStartLookup() whenever the urlbar
is set a value using urlbar.setAttribute() && the urlbar has focus. It should 
fire the call only for keypress events.
(Assignee)

Comment 1

18 years ago
I cannot use keypress events else autocomplete won't work with IME. However, I can ignore those oninput events 
that are generated when setting the value of the text field.

I nominate this bug for beta3 as it disturbes the urlbar of the browser. This problem will start affecting the 
browser url bar when Radha checkin the fix for bug 41775.
Status: NEW → ASSIGNED
Keywords: nsbeta3
Target Milestone: --- → M18
(Assignee)

Comment 2

18 years ago
Created attachment 12027 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

18 years ago
Whiteboard: Fix in hand
(Assignee)

Comment 3

18 years ago
Radha, can you try the patch to see if you are satified with it. Thanks

Updated

18 years ago
Keywords: mail2
this got fixed last week
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

18 years ago
No, it has not yet been checked in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 6

18 years ago
*** Bug 47397 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Go ahead, nsbeta3+
Whiteboard: Fix in hand → [nsbeta3+]Fix in hand
(Assignee)

Comment 8

18 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+]Fix in hand → [nsbeta3+]

Comment 9

17 years ago
verified patch is in (cvs version 1.201)
Status: RESOLVED → VERIFIED

Comment 10

17 years ago
removing mail2 keyword.
Keywords: mail2
You need to log in before you can comment on or make changes to this bug.