Autocomplete comes up inappropriately (when user isn't typing into urlbar)

VERIFIED DUPLICATE of bug 46678

Status

()

Core
Document Navigation
P3
normal
VERIFIED DUPLICATE of bug 46678
18 years ago
10 years ago

People

(Reporter: Jason Eager, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The autocomplete menu is coming up when I use the drop-down url bar
to select a base url (www.trimble.co.nz) that I have also typed in
specific pages for (www.trimble.co.nz/specificpage/blah.html). This
is especially annoying because I have http://www.trimble.co.nz set up
as my home page (INTRANET ONLY SITE), and when mozilla starts up, I get an
autocomplete menu with the three specific pages I accessed on that website.

The autocomplete menu should only come up when:

1) The url bar text field has focus, AND
2) The user has typed at least ONE character into the url bar since it gained
focus.

EXAMPLE: if I've manually entered http://www.blah.com AND
http://www.blah.com/thissucks/samplepage.html and
http://www.blah.com/thisalsosucks/samplepage2.html, and then I use the drop down
menu to select "http://www.blah.com" and then I click to give the url bar text
field focus, the auto complete menu should NOT pop up immediately, it should
wait until I have typed at LEAST one character.

Comment 1

18 years ago
*** Bug 47431 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
->History
Assignee: ben → radha
Component: XP Apps: GUI Features → History
QA Contact: sairuh → claudius
ducarroz has a bug on this. Hopefully he will checkin soon. 

*** This bug has been marked as a duplicate of 46678 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.