Thunderbird crashes when sending mail with attachment with no filename extention

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tommy Meldgaard, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-01-10)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111415 Mandriva/1.9.0.4-0.1mdv2009.0 (2009.0) Firefox/3.0.4
Build Identifier: Version 2.0.0.17 (20080929) and also version 2.0.0.18 (20081120)

When sending mails with a attachment Thunderbird crashes if the filename of the attachment has no extention.

The error is:

/usr/lib/thunderbird-2.0.0.17/run-mozilla.sh: line 131: 19066 Segmentation fault      (core dumped) "$prog" ${1+"$@"}

Reproducible: Always

Steps to Reproduce:
1. Create a mail with an attachment. The attachment filename has no extention.
2. Send mail.

Actual Results:  
Thunderbird crashes.

Expected Results:  
Send the email.

Comment 1

10 years ago
Please give crash ids for these crashes, and try in Safe Mode. Also update Thunderbird.
Keywords: crash
Version: unspecified → 2.0

Comment 2

10 years ago
You might try beta 1, which should get you a crash report
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 http://kb.mozillazine.org/Breakpad#Viewing_reports

backup your profile first, and install thunderbird 3 into it's own directory

In any event, please report your results. No dupe found in fixed or open bugs
Whiteboard: closeme 2009-01-10
(Reporter)

Comment 3

10 years ago
Was only a problem on Mandrivas rpm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Works for me because we didn't change anything here.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.