Bug 467198 (bz-release-321)

Release Bugzilla 3.3.2, 3.2.1, 3.0.7, and 2.22.7

RESOLVED FIXED

Status

()

Bugzilla
Bugzilla-General
--
blocker
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

(Blocks: 1 bug)

Dependency tree / graph
Bug Flags:
blocking3.2.1 +
blocking3.0.7 +
blocking2.22.7 +

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
We are freezing for Bugzilla 3.4 in exactly two months. So, sometime in the next two weeks, I want to release a 3.3.1 development release, so people have enough time to give feedback before we freeze. I want to do this regardless of whether there's a 3.2.1 or 3.0.7 to release.

Updated

9 years ago
Depends on: 468249
(Assignee)

Comment 1

9 years ago
Okay, thanks to almost all the sec bugs being ready, we're going to expand this into several releases.
Summary: Release Bugzilla 3.3.1 → Release Bugzilla 3.3.1, 3.2.1, 3.0.7, and 2.22.7
(Assignee)

Updated

9 years ago
Depends on: 472041
(Assignee)

Comment 2

9 years ago
For anybody interested, I plan to do this release between Tuesday and Friday of this week.
(Assignee)

Updated

9 years ago
Depends on: 472045
(Assignee)

Updated

9 years ago
Alias: bz-release-321
(Assignee)

Updated

9 years ago
Depends on: 472078
(Assignee)

Updated

9 years ago
Depends on: 472080
(Assignee)

Updated

9 years ago
Depends on: 472084

Comment 3

9 years ago
Do we postpone bug 467920, bug 470486, bug 464992?

All of them are Windows-related regressions.

Comment 4

9 years ago
Yes, we postpone them all. As long as we don't know what the problem is, it doesn't make sense to block releases for something which is not reproducible.
(Assignee)

Comment 5

9 years ago
Because justdave wants a fix for bug 472206 before we release 3.2.1, we need to release a 3.3.1 before we do all this (because we urgently need a development release, since we freeze on Jan 29).
Summary: Release Bugzilla 3.3.1, 3.2.1, 3.0.7, and 2.22.7 → Release Bugzilla 3.3.2, 3.2.1, 3.0.7, and 2.22.7
(Assignee)

Updated

9 years ago
No longer depends on: 472045
(Assignee)

Updated

9 years ago
Depends on: 476040
(Assignee)

Updated

9 years ago
Depends on: 476045
(Assignee)

Updated

9 years ago
Depends on: 476061
(Assignee)

Updated

9 years ago
Flags: blocking3.2.1+
Flags: blocking3.0.7+
Flags: blocking2.22.7+
(Assignee)

Comment 6

9 years ago
This release is going to happen on Monday. We don't want to spring a major security update on sysadmins on Friday. Everything is pretty much ready for the release though, so it shouldn't be any problem to do it Monday.
(Assignee)

Comment 7

9 years ago
Okay, all the security patches have been checked in. We just have to wait now for all the tinderboxen to pass, and then we can start the release process.
Status: NEW → ASSIGNED
(Assignee)

Comment 8

9 years ago
Okay, I'm starting the release process now.
(Assignee)

Comment 9

9 years ago
I've bumped all the version numbers.
(Assignee)

Comment 10

9 years ago
Releases tagged.
(Assignee)

Comment 11

9 years ago
Tarballs rolled and posted.
(Assignee)

Comment 12

9 years ago
Created attachment 360185 [details] [diff] [review]
Monolithic Website Patch

Here's the web site updates that I'm about to check in.
Assignee: general → mkanat
(Assignee)

Comment 13

9 years ago
Okay, website updates checked in. Now we just have to wait for the site to rebuild itself, and then kick the Netscaler.
(Assignee)

Comment 14

9 years ago
Okay, FreshMeat updated, LpSolit updated bugzilla-update.xml, I sent out all the announcements and the advisory, and now we're all done.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.