Closed Bug 467809 Opened 11 years ago Closed 11 years ago

Advanced address search recognizes only the first condition

Categories

(Thunderbird :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: henning.henkel, Assigned: philor)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111922 GranParadiso/3.0.4
Build Identifier: 20081201162550

When selecting "all conditions must be matched" and searching for example a lastname and a nickname and provide names, I get two matches with the same lastname. But it should only show one match, as the other contact has no nickname.

Reproducible: Always

Steps to Reproduce:
1.Create two contacts with the same or partly the same lastname
2.One of the contacts gets a nickname, the other one not.
3.Press SHIFT + F when in the addressbook 
4.Select "all conditions must be matched"
5.Search for "Name" "contains" the above chosen lastname ( or part of it )
6.Add another codition for the nickname with "contains" and the before chosen nick.
7. Press enter to search
Actual Results:  
Both contact are shown

Expected Results:  
Only the contact should be shown who matches all the conditiones
Flags: blocking-thunderbird3.0b1?
Blocks: 463057
As a side effect I noticed that a new search (in the same window by hitting "new search") after the above mentioned procedure does not show any results.
This stops us from bombing out with

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/ABSearchDialog.js :: GetScopeForDirectoryURI :: line 122"  data: no]

when you change from "Match any" to "Match all", since we're currently trying to setSearchScope(""). Testing it makes another bug rather obvious, since you open the dialog with "Any Name" selected, and when you change to "Match all" that changes to "Display Name" because the "Any Name" item disappears. I'll assert that that's a different bug which this one was just masking, since I don't actually know what's doing that.
Assignee: nobody → philringnalda
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #351321 - Flags: superreview?(bugzilla)
Attachment #351321 - Flags: review?(bugzilla)
Attachment #351321 - Flags: superreview?(bugzilla)
Attachment #351321 - Flags: superreview+
Attachment #351321 - Flags: review?(bugzilla)
Attachment #351321 - Flags: review+
Comment on attachment 351321 [details] [diff] [review]
Fix v.1
[Checkin: Comment 4]

Please file a bug on the Any Name issue and I'll take a look at it later.
http://hg.mozilla.org/comm-central/rev/5c3297d72cb6
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3.0b1-
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b2
Version: unspecified → Trunk
Depends on: 467915
Blocks: 449260
Keywords: regression
Blocks: 467813
Phil, this made it into b1, do you want the target revised?
S'pose so.
Target Milestone: Thunderbird 3.0b2 → Thunderbird 3.0b1
Attachment #351321 - Attachment description: Fix v.1 → Fix v.1 [Checkin: Comment 4]
You need to log in before you can comment on or make changes to this bug.