thread pane doesn't show all unread messages, while folder pane's count shows them

RESOLVED INCOMPLETE

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED INCOMPLETE
10 years ago
6 years ago

People

(Reporter: marcin_mail2005, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111415 Mandriva/1.9.0.4-0.1mdv2009.0 (2009.0) Firefox/3.0.4
Build Identifier: 2.0.0.18 (20081120)

Left pane (accounts and folders) shows unread messages and it's fine. But message title pane (top one) doesn't show them all, like it was hidden or missing message somewhere.
It started to appear when I've installed an extension to avoid duplicates. But it worked not fine, so I deinstalled it.
But issue still appears and I can't read all the messages as an effect.

Reproducible: Always

Steps to Reproduce:
1.Install Remove Duplicate Messages add on (https://addons.mozilla.org/pl/thunderbird/addon/4654)
2.Try to remove some duplicates (roughly 10-15 should be enough)
3.A bug should appear - message with empty title in message title pane
4.Add on can be uninstalled
5.Try to download some messages, especially from the same sender and title (duplicates are welcome)
6. Left window should display unread messages, but top-righ pane should list not all of them.
Actual Results:  
Left window contains unread messages and message title pane doesn't show all of them. Today's example: Thunderbird shows me 1 unread messsage in left pane and I can't find anything unread in top-right (massage title) pane.
It's not like I have this message in the list, but marked as unread - physicalyy there's no such message at all.

Expected Results:  
Top-right (massage title) pane should display all unread messages.

Updated

9 years ago
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Summary: title pane doesn't show all unread messages, whether left pane shows them → thread pane doesn't show all unread messages, whether left pane's count shows them
Whiteboard: dupeme
I've often seen (including tb3pre) that when a new message arrives, under certain circumstances (like focus on last msg in thread pane?), the new messages is not added to the thread pane, which seems to be the problem of this bug.
I do think we have a bug for this already, so dupeme!
Summary: thread pane doesn't show all unread messages, whether left pane's count shows them → thread pane doesn't show all unread messages, while folder pane's count shows them

Comment 2

6 years ago
question is, does marcin still see the problem?
Whiteboard: dupeme → [closeme 2012-04-15][dupeme?]

Comment 3

6 years ago
Closed per Whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2012-04-15][dupeme?] → [dupeme?]

Updated

6 years ago
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.