Frequent crashes in nsXBLBinding::InitClass()

VERIFIED FIXED in M18

Status

()

Core
XBL
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Akkana Peck, Assigned: David Hyatt)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][nsbeta3+] Fixed on trunk, awaiting approval for branch)

(Reporter)

Description

18 years ago
I'm seeing very frequent crashes in the builds over the last few weeks while
trying to eat dogfood; most often in mail replies, but also doing other things.

I have a chrome directory, and a user.css inside that chrome directory; I think
this may have something to do with why I'm seeing an unusually large number of
these (I tried removing my chrome directory and my easily reproducible crash on
exit went away; can't tell whether these other random crashes go away since they
are fairly random).
(Reporter)

Comment 1

18 years ago
Talkback trace from
http://climate/reports/incidenttemplate.CFM?reportID=124&style=0&tc=44&cp=1&ck1=SStack+crawl+signature&cd1=%25nsXBLBinding%3A%3AInitClass%28%29%25&co1=like&bbid=14940128
:

nsXBLBinding::InitClass()
nsXBLBinding::InstallProperties()       nsXBLService::LoadBindings()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructXULFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructXULFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructXULFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructXULFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructXULFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructDocElementFrame()
nsCSSFrameConstructor::ContentInserted()       StyleSetImpl::ContentInserted()
     PresShell::InitialReflow()       nsXULDocument::StartLayout()
nsXULDocument::ResumeWalk()       OnStopRequest()
nsDocumentOpenInfo::OnStopRequest()
nsCachedChromeChannel::HandleStopLoadEvent()       PL_HandleEvent()
PL_ProcessPendingEvents()       nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()       our_gdk_io_invoke()       libglib-1.2.so.0 +
0xeaca (0x4075faca)       libglib-1.2.so.0 + 0x10186 (0x40761186)
libglib-1.2.so.0 + 0x10751 (0x40761751)       libglib-1.2.so.0 + 0x108f1
(0x407618f1)       libgtk-1.2.so.0 + 0x8c5b9 (0x406865b9)
nsAppShell::Run()       nsAppShellService::Run()       main1()       main()
  libc.so.6 + 0x189cb (0x4024d9cb)   
Keywords: crash

Comment 2

18 years ago
looking though some of the talkback data we see some possible
related problems that might be XP...

nsXBLBinding::InitClass
Stack Trace: 
nsXBLBinding::InitClass 
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLBinding.cpp
nsXBLBinding::InstallProperties 
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLBinding.cpp
nsXBLService::LoadBindings      
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLService.cpp
nsCSSFrameConstructor::ConstructFrameInternal   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructFrame   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ProcessChildren  
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructXULFrame        
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructFrameInternal   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructFrame   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ProcessChildren  
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructXULFrame        
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructFrameInternal   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructFrame   
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ProcessChildren  
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ConstructDocElementFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
nsCSSFrameConstructor::ContentInserted  
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
StyleSetImpl::ContentInserted   
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp
PresShell::InitialReflow        
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
nsXULDocument::StartLayout      
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp
nsXULDocument::ResumeWalk       
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp
nsXULDocument::CachedChromeStreamListener::OnStopRequest        
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp
nsDocumentOpenInfo::OnStopRequest       
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp
nsCachedChromeChannel::HandleStopLoadEvent      
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeProtocolHandler.cpp
PL_HandleEvent  [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c
_md_EventReceiverProc   [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00688b42

    nsXBLBinding::InitClass 3543fd29
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000071921 CrashDate: 2000-07-20 UptimeMinutes: 183  Total: 183 
        OS: Windows NT  4.0 build 1381
        URL: http://freshmeat.net
        Comment: Picked "Mozilla Mail" off the Tasks menu.
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14525075

    nsXBLBinding::InitClass 9c177841
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000071911 CrashDate: 2000-07-20 UptimeMinutes: 251  Total: 251 
        OS: Windows NT  4.0 build 1381
        URL: www.bhphoto.com
        Comment: submitting a form to the site.
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14536440

    nsXBLBinding::InitClass 111d7aac
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000071921 CrashDate: 2000-07-21 UptimeMinutes: 295  Total: 638 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14558670

    nsXBLBinding::InitClass 6795dab4
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000071921 CrashDate: 2000-07-21 UptimeMinutes: 176  Total: 240 
        OS: Windows 98  4.10 build 67766446
        URL: www.dansteinman.com
        Comment: Viewing the dynapi examples index
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14560591

    nsXBLBinding::InitClass 0c10c60f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072009 CrashDate: 2000-07-21 UptimeMinutes: 229  Total: 229 
        OS: Windows NT  4.0 build 1381
        URL: http://www.securityfocus.com/pager
        Comment: Had a couple of windows open...  last thing I did (which was a 
minute or so before the crash) is to click on the download of the security focus 
pager binary for windows
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14562221

    nsXBLBinding::InitClass b19e9382
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072021 CrashDate: 2000-07-22 UptimeMinutes: 174  Total: 311 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14618156

    nsXBLBinding::InitClass e06232cd
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072109 CrashDate: 2000-07-22 UptimeMinutes: 469  Total: 511 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: crash on starting Composer (probably out of memory? browser had 
been up
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14647576

    nsXBLBinding::InitClass 767a3049
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072109 CrashDate: 2000-07-24 UptimeMinutes: 266  Total: 266 
        OS: Windows NT  4.0 build 1381
        URL: ftp://ftp.mozilla.org/pub/mozilla/nightly/latest
        Comment: trying to download mozilla nightly
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14711290

    nsXBLBinding::InitClass ed997a0f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072409 CrashDate: 2000-07-24 UptimeMinutes: 104  Total: 104 
        OS: Windows NT  4.0 build 1381
        URL: http://linuxtoday.com
        Comment: Choose the "Tasks/Mozilla Mail" menu item and it immediately 
crashed.
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14733499

    nsXBLBinding::InitClass b46f1771
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000071921 CrashDate: 2000-07-25 UptimeMinutes: 50  Total: 50 
        OS: Windows NT  5.0 build 2195
        URL: www.escribe.com
        Comment: Did a search for bmail-dev in the search field of the website
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14750183

    nsXBLBinding::InitClass ec60e6ad
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072421 CrashDate: 2000-07-25 UptimeMinutes: 18  Total: 18 
        OS: Windows NT  4.0 build 1381
        URL: http://slashdot.org
        Comment: downloading the java plugin.  When I clicked the button to do 
the http download
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14767633

    nsXBLBinding::InitClass a545624b
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072409 CrashDate: 2000-07-25 UptimeMinutes: 272  Total: 272 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14774636

    nsXBLBinding::InitClass 3a7730bb
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072421 CrashDate: 2000-07-25 UptimeMinutes: 117  Total: 117 
        OS: Windows NT  4.0 build 1381
        URL: http://www.geocities.com/Hollywood/5286/kyle.html
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14785965

    nsXBLBinding::InitClass 13aabb87
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072409 CrashDate: 2000-07-25 UptimeMinutes: 380  Total: 380 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14790788

    nsXBLBinding::InitClass ed997a0f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072421 CrashDate: 2000-07-25 UptimeMinutes: 189  Total: 189 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: Deleting web mail
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14793164

    nsXBLBinding::InitClass 1dc88508
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072021 CrashDate: 2000-07-26 UptimeMinutes: 185  Total: 203 
        OS: Windows 95  4.0 build 67109975
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14831075

    nsXBLBinding::InitClass 3768c85f
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072421 CrashDate: 2000-07-26 UptimeMinutes: 8  Total: 8 
        OS: Windows NT  4.0 build 1381
        URL: (internal firewalled)
        Comment: did a find on the page after opening a new window to it and 
before the find dialog displayed -- can't reproduce the problem though.
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14839258

    nsXBLBinding::InitClass e9c46883
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072521 CrashDate: 2000-07-27 UptimeMinutes: 63  Total: 327 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14873719

    nsXBLBinding::InitClass ce1ddfb4
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072009 CrashDate: 2000-07-27 UptimeMinutes: 35  Total: 35 
        OS: Windows 98  4.10 build 67766446
        URL: www.battle.net
        Comment: Was reading the strategy forums for Diablo II.  I highlighted a 
block of text to copy.  I moved my mouse over the frame buttons on the hand side 
and it crashed.  I was attempting to go to the edit menu and hit copy but it 
crashed. 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14885592

    nsXBLBinding::InitClass b50a9475
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xbl/src/nsXBLBinding.
cpp line 1115
        Build: 2000072409 CrashDate: 2000-07-27 UptimeMinutes: 177  Total: 329 
        OS: Windows 98  4.10 build 67766222
        URL: ftp.mozilla.org/pub/mozilla/nightly/latest/
        Comment: Clicking the download link to the latest nightly Win32 Talkback 
build (mozilla-win32-talkback.zip). I had previously done so
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14900365


Keywords: nsbeta2, topcrash

Comment 3

18 years ago
It is very late to take a fix for this.  If we can get info on what fix is, and 
if it is very low risk, maybe we can approve for PR2.  Putting on [NEED INFO] 
for now.
Whiteboard: [NEED INFO]

Comment 4

18 years ago
nsbeta3+ so you can justify working on it,and hopefully getting a fix into nsbeta2.
Keywords: nsbeta3
Whiteboard: [NEED INFO] → [NEED INFO][nsbeta3+]
Target Milestone: --- → M18

Comment 5

18 years ago
[@ nsXBLBinding::InitClass] - for topcrash tracking.
(Assignee)

Comment 6

18 years ago
Darn, I can't reproduce this.  I need the real line it's crashing on.  The file 
has changed, so I need a new accurate report using an M18 trunk.  I suspect that 
I might have fixed this with my last XBL checkin, but it's hard to know for 
sure.

I'll only be investigating this further if someone reproduces it using a current 
trunk build (m18).  Until then, I'm off to greener past... err... bugs.



Status: NEW → ASSIGNED

Comment 7

18 years ago
This crash still happens in the latest builds. Atleast 10+ crashes are reported 
in the last 10 days.


nsXULTreeOuterGroupFrame::FindPreviousRowContent
Stack Trace: 
nsXULTreeOuterGroupFrame::FindPreviousRowContent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp
nsXULTreeOuterGroupFrame::InternalPositionChanged
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp
nsXULTreeOuterGroupFrame::PositionChanged
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsXULTreeOuterGroupFrame.cpp
nsSliderFrame::SetCurrentPosition
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSliderFrame.cpp
nsSliderFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSliderFrame.cpp
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp
USER32.dll + 0x1820 (0x77e71820)
0x00f9009d

nsXULTreeOuterGroupFrame::FindPreviousRowContent 1cf70567

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072409 CrashDate: 2000-07-24 UptimeMinutes: 165 Total: 165 
OS: Windows NT 4.0 build 1381
URL: 
Comment: Crashed when scrolling in Mail
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14725791

nsXULTreeOuterGroupFrame::FindPreviousRowContent 4907d116

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072409 CrashDate: 2000-07-24 UptimeMinutes: 16 Total: 68 
OS: Windows NT 5.0 build 2195
URL: 
Comment: scrolling "viciously" in the bookmarks manager (grab and drag up and
down rapidly).
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14727639

nsXULTreeOuterGroupFrame::FindPreviousRowContent a13d3555

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072409 CrashDate: 2000-07-24 UptimeMinutes: 37 Total: 37 
OS: Windows NT 4.0 build 1381
URL: 
Comment: crash again with deleting the last message in thread pane and then
scrolling in the folder pane. Known bug reported. 7-24 am build. win32.
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14729525

nsXULTreeOuterGroupFrame::FindPreviousRowContent 660a97b5

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072409 CrashDate: 2000-07-25 UptimeMinutes: 231 Total: 396 
OS: Windows NT 4.0 build 1381
URL: 
Comment: Crashed while scrolling in Mail
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14767992

nsXULTreeOuterGroupFrame::FindPreviousRowContent 6f5baa51

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072409 CrashDate: 2000-07-25 UptimeMinutes: 108 Total: 108 
OS: Windows NT 4.0 build 1381
URL: 
Comment: 
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14787009

nsXULTreeOuterGroupFrame::FindPreviousRowContent 233b26b5

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072421 CrashDate: 2000-07-25 UptimeMinutes: 54 Total: 54 
OS: Windows 98 4.10 build 67766446
URL: 
Comment: Opening IMAP "INBOX" after having selected another folder and not
waited for action to be finished.
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14835330

nsXULTreeOuterGroupFrame::FindPreviousRowContent 5747ba5a

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072509 CrashDate: 2000-07-26 UptimeMinutes: 267 Total: 267 
OS: Windows NT 4.0 build 1381
URL: www.mirc-colors.com
Comment: trying to leave the page.
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14851509

nsXULTreeOuterGroupFrame::FindPreviousRowContent eaada389

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072609 CrashDate: 2000-07-27 UptimeMinutes: 16 Total: 25 
OS: Windows NT 5.0 build 2195
URL: 
Comment: Scrolling the message pane in mail /news
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14881982

nsXULTreeOuterGroupFrame::FindPreviousRowContent 11d4e2e6

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072509 CrashDate: 2000-07-25 UptimeMinutes: 4 Total: 4 
OS: Windows 98 4.10 build 67766222
URL: 
Comment: 
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14882515

nsXULTreeOuterGroupFrame::FindPreviousRowContent cc949fc6

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/xul/base/src/nsXULTre
eOuterGroupFrame.cpp
line 838
Build: 2000072509 CrashDate: 2000-07-27 UptimeMinutes: 84 Total: 87 
OS: Windows NT 4.0 build 1381
URL: 
Comment: 
Stacktrace: http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14889612

(Reporter)

Comment 8

18 years ago
On Friday I was seeing this a lot in branch builds -- it's very definitely on
the beta2 branch.  I believe it's on the trunk too -- I've been seeing lots of
random crashes for several weeks, since before the branch was cut.

Comment 9

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. Hyatt, if you get a fix for 
this in the next couple of days, please explain the risk of the fix and 
renominate for nsbeta2.
Whiteboard: [NEED INFO][nsbeta3+] → [nsbeta3+][nsbeta2-]

Comment 10

18 years ago
*** Bug 47067 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
Spoke with triage team.  This bug happening to many people on Linux branch and 
trunk.  Puttting on [nsbeta2+] radar.  Though mostly seen on replying to mail, 
also get same stack trace on crash loading ftp://ftp.netscape.com and Open|File.

We really need this fixed for PR2.
Whiteboard: [nsbeta3+][nsbeta2-] → [nsbeta2+][nsbeta3+]

Comment 12

18 years ago
Spoke with trudelle, really need hyatt to help on this.  pavlov looking into 
this until we can locate hyatt.  Putting on ETA 8/01 to re-review status 
for a PR2 fix tomorrow.
Whiteboard: [nsbeta2+][nsbeta3+] → [nsbeta2+][nsbeta3+]ETA 8/01
(Assignee)

Comment 13

18 years ago
Fix checked in on trunk.  Awaiting PDT approval to check in on branch.
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta2+][nsbeta3+]ETA 8/01 → [nsbeta2+][nsbeta3+] Fixed on trunk, awaiting approval for branch

Comment 14

18 years ago
Yes...check in to branch!!!  ASAP.
(Assignee)

Comment 15

18 years ago
fixed everywhere.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
no longer see the crashes on the m17 linux build 2000-08-02-04-M17; verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.